dev-python/lit: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 20:38:30 +0000 (21:38 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 20:54:41 +0000 (21:54 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/lit/lit-10.0.0.9999.ebuild
dev-python/lit/lit-11.0.0.9999.ebuild
dev-python/lit/lit-7.1.0.ebuild
dev-python/lit/lit-8.0.1.ebuild
dev-python/lit/lit-9.0.1.ebuild

index 4996ccd73ba8c4acd3f0524f6da268b0ea8b915b..d53547c725e050afec3fe1f322f2347610dde55c 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
 inherit distutils-r1 llvm.org multiprocessing
 
 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
@@ -19,7 +21,6 @@ RESTRICT="!test? ( test )"
 
 # Tests require 'FileCheck' and 'not' utilities (from llvm)
 BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/psutil[${PYTHON_USEDEP}]
                sys-devel/llvm )"
index 4996ccd73ba8c4acd3f0524f6da268b0ea8b915b..d53547c725e050afec3fe1f322f2347610dde55c 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
 inherit distutils-r1 llvm.org multiprocessing
 
 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
@@ -19,7 +21,6 @@ RESTRICT="!test? ( test )"
 
 # Tests require 'FileCheck' and 'not' utilities (from llvm)
 BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/psutil[${PYTHON_USEDEP}]
                sys-devel/llvm )"
index c9d754973b917426bfbbb2e7c768a574909d5fcb..0d76068cd76e1bfe6fe54a453697fcb1186bcc07 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=6
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
 inherit distutils-r1 multiprocessing
 
 MY_P=llvm-${PV/_/}.src
@@ -21,7 +23,6 @@ S=${WORKDIR}/${MY_P}/utils/lit
 
 # Tests require 'FileCheck' and 'not' utilities (from llvm)
 DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/psutil[${PYTHON_USEDEP}]
                sys-devel/llvm )"
index 9fb91951383ff90f517737ba46cfc866f5fa7807..03682e862735123202817373a0dfba3cfe50e0f1 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=6
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
 inherit distutils-r1 multiprocessing
 
 MY_P=llvm-${PV/_/}.src
@@ -21,7 +23,6 @@ S=${WORKDIR}/${MY_P}/utils/lit
 
 # Tests require 'FileCheck' and 'not' utilities (from llvm)
 DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/psutil[${PYTHON_USEDEP}]
                sys-devel/llvm )"
index a3b7d11a88e328773d0a212ba3e6ccd292f2db74..c87eead5cb39937a446c878236206a4ea326ba7c 100644 (file)
@@ -3,7 +3,9 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
 inherit distutils-r1 llvm.org multiprocessing
 
 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
@@ -19,7 +21,6 @@ RESTRICT="!test? ( test )"
 
 # Tests require 'FileCheck' and 'not' utilities (from llvm)
 BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/psutil[${PYTHON_USEDEP}]
                sys-devel/llvm )"