dev-python/cheetah3: Fix tests
authorMichał Górny <mgorny@gentoo.org>
Tue, 5 May 2020 13:59:21 +0000 (15:59 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 5 May 2020 14:24:45 +0000 (16:24 +0200)
Closes: https://bugs.gentoo.org/720982
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cheetah3/cheetah3-3.2.4.ebuild

index 6e9a3455e1f020414d5ab154d5dcf4548d6809e6..290c94fd2abcc38f648a31114845e255d2773507 100644 (file)
@@ -23,9 +23,6 @@ BDEPEND="${RDEPEND}"
 
 DOCS=( ANNOUNCE.rst README.rst TODO )
 
-# Race in the test suite
-DISTUTILS_IN_SOURCE_BUILD=1
-
 python_prepare_all() {
        # Disable broken tests.
        sed \
@@ -41,5 +38,5 @@ python_test() {
        cp -r "${S}/Cheetah/Tests/ImportHooksTemplates" \
                "${BUILD_DIR}/lib/Cheetah/Tests/ImportHooksTemplates" || die
 
-       "${PYTHON}" Cheetah/Tests/Test.py || die "Tests fail with ${EPYTHON}"
+       "${EPYTHON}" Cheetah/Tests/Test.py || die "Tests fail with ${EPYTHON}"
 }