mail-filter/postfwd: added new version 2.00
authorMarc Schiffbauer <mschiff@gentoo.org>
Wed, 27 Mar 2019 14:15:48 +0000 (15:15 +0100)
committerMarc Schiffbauer <mschiff@gentoo.org>
Wed, 27 Mar 2019 14:20:49 +0000 (15:20 +0100)
Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

mail-filter/postfwd/Manifest
mail-filter/postfwd/files/postfwd.conf.3 [new file with mode: 0644]
mail-filter/postfwd/files/postfwd.init.3 [new file with mode: 0644]
mail-filter/postfwd/files/postfwd.service.3 [new file with mode: 0644]
mail-filter/postfwd/postfwd-2.00.ebuild [new file with mode: 0644]

index 1f4ca05ea01bb623f2b06bfb952269cb5f6b32a3..28c0ed381dafd496a48df4a5b351f48a6c7539ee 100644 (file)
@@ -1 +1,2 @@
 DIST postfwd-1.35.tar.gz 354609 BLAKE2B 8e85db37d7f81be4613d9c2e411760af48650125af7b22439e3b47a8c3c7285564bfcd7a9fe4eed35d2603ddf80dcdf11d75f84afcaf3e57d53c4e986068f06c SHA512 7b0e8c8a755f085c108c45b28ec8c32139581ce129d0b8586f1876ae87f134a4fb1606d45105ccfa62351ca2d3b87f001ea52aacab0680f3345c41562bec5207
+DIST postfwd-2.00.tar.gz 265346 BLAKE2B ec67bffb5f6959e9516965516688e72f337f717a3159a094dc0373331a5fc09a451f664643a7f3e739b28d4137c130acfb39129b8557b4d41f4d445679f52623 SHA512 b9994b7dd96f1460d66ef35f173c5a4a4d72beb5b955092349304eae2672182874f07236fe5512ba3d0ecc68e2f0472e76b3667ded011536b0cf6f2d874bb039
diff --git a/mail-filter/postfwd/files/postfwd.conf.3 b/mail-filter/postfwd/files/postfwd.conf.3
new file mode 100644 (file)
index 0000000..578b051
--- /dev/null
@@ -0,0 +1,18 @@
+# /etc/conf.d/postfwd.conf
+
+# User and group to execute postfwd as
+POSTFWD_USER="postfwd"
+POSTFWD_GROUP="postfwd"
+
+# Configuration file to use
+POSTFWD_CONFIG="/etc/postfwd.cf"
+
+# The IP address postfwd will listen on
+# WARNING: You _really_ want this to be localhost for security!
+POSTFWD_LISTEN="127.0.0.1"
+
+# The port postfwd will listen on
+POSTFWD_PORT="10040"
+
+# Additional options to pass to postfwd
+POSTFWD_OPTS=""
diff --git a/mail-filter/postfwd/files/postfwd.init.3 b/mail-filter/postfwd/files/postfwd.init.3
new file mode 100644 (file)
index 0000000..7fc1734
--- /dev/null
@@ -0,0 +1,27 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+PIDFILE=/var/run/postfwd.pid
+
+depend() {
+       need net
+}
+
+start() {
+       ebegin "Starting postfwd"
+               start-stop-daemon --start --quiet --background \
+               --pidfile ${PIDFILE} \
+               --exec /usr/sbin/postfwd3 -- --daemon --file ${POSTFWD_CONFIG} \
+                       --interface=${POSTFWD_LISTEN} --port=${POSTFWD_PORT} \
+                       --user=${POSTFWD_USER} --group=${POSTFWD_GROUP} \
+                       --pidfile ${PIDFILE} \
+                       ${POSTFWD_OPTS}
+       eend $?
+}
+
+stop() {
+       ebegin "Stopping postfwd"
+               start-stop-daemon --stop --quiet --pidfile ${PIDFILE}
+       eend $?
+}
diff --git a/mail-filter/postfwd/files/postfwd.service.3 b/mail-filter/postfwd/files/postfwd.service.3
new file mode 100644 (file)
index 0000000..b1d3b45
--- /dev/null
@@ -0,0 +1,11 @@
+[Unit]
+Description=Postfix firewall daemon
+
+[Service]
+Type=forking
+ExecStart=/usr/sbin/postfwd3 --shortlog --summary=600 --cache=600 --cache-rbl-timeout=3600 --cleanup-requests=1200 --cleanup-rbls=1800 --cleanup-rates=1200 --daemon --file=/etc/postfwd.cf --interface=127.0.0.1 --port=10040 --pidfile=/var/run/postfwd.pid --user=postfwd --group=postfwd
+ExecStop=/usr/sbin/postfwd3 --file=/etc/postfwd.cf --pidfile=/var/run/postfwd.pid --kill
+ExecReload=/usr/sbin/postfwd3 --file=/etc/postfwd.cf --pidfile=/var/run/postfwd.pid --reload
+
+[Install]
+WantedBy=multi-user.target
diff --git a/mail-filter/postfwd/postfwd-2.00.ebuild b/mail-filter/postfwd/postfwd-2.00.ebuild
new file mode 100644 (file)
index 0000000..f4ce5c3
--- /dev/null
@@ -0,0 +1,97 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils user systemd
+
+DESCRIPTION="Versatile Postfix policy server with a flexible ruleset based configuration"
+HOMEPAGE="http://www.postfwd.org/"
+SRC_URI="http://www.postfwd.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+tools"
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5.16.3
+       dev-perl/Net-CIDR-Lite
+       dev-perl/Net-DNS
+       dev-perl/Net-Server
+       dev-perl/NetAddr-IP
+       virtual/perl-Digest-MD5
+       virtual/perl-Storable
+       virtual/perl-Sys-Syslog
+       virtual/perl-Time-HiRes
+"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+       enewgroup postfwd
+       enewuser postfwd -1 -1 -1 postfwd
+}
+
+src_install() {
+       local BIN="postfwd3"
+       # programs and tools
+       dosbin "${S}"/sbin/${BIN}
+
+       # man pages and documentation
+       doman "${S}"/man/man8/${BIN}.8
+       dodoc "${S}"/doc/{${BIN}.CHANGELOG,${BIN}.txt}
+
+       # example configuration(s)
+       insinto /usr/share/doc/${PF}/examples
+       newins "${S}"/etc/${PN}.cf.sample ${PN}.cf.dist
+
+       # plugins
+       dodoc -r "${S}"/plugins
+
+       # tools
+       if use tools; then
+               dodoc -r "${S}"/tools
+       fi
+
+       # start scripts script and respective configuration file
+       newinitd "${FILESDIR}"/${PN}.init.3 ${PN}
+       newconfd "${FILESDIR}"/${PN}.conf.3 ${PN}
+       systemd_newunit "${FILESDIR}"/${PN}.service.3 ${PN}.service
+}
+
+pkg_postinst() {
+       einfo
+       einfo "${PN} has no default configuration for safety reasons. Every"
+       einfo "mail system is different, so you should craft a set of rules"
+       einfo "that is suitable for your environment and save it to:"
+       einfo "   /etc/postfwd.cf"
+       einfo "You can find example configurations in:"
+       einfo "   /usr/share/doc/${PF}/examples"
+       einfo
+       einfo "If you want ${PN} to start on system boot, you have to add it your"
+       einfo "default run level if using OpenRC:"
+       einfo "   # rc-update add postfwd default"
+       einfo "Also remember to edit /etc/conf.d/${PN} to your liking."A
+       einfo
+       einfo "Or - if you are using systemd - enable the service:"
+       einfo "   # systemctl enable postfwd"
+       einfo
+       einfo "A plugins sample folder has been placed under:"
+       einfo
+       einfo "   /usr/share/doc/${PF}/plugins"
+
+       if use tools; then
+               einfo
+               einfo "You can find additional tools for testing ${PN} in:"
+               einfo "   /usr/share/doc/${PF}/tools"
+       fi
+
+       ewarn
+       ewarn "Please read the documentation carefully and properly test new"
+       ewarn "rulesets before putting them into production use. Otherwise you"
+       ewarn "risk accidental mail loss or worse."
+       ewarn
+       ewarn "Visit http://www.postfwd.org/ for more information."
+       ewarn
+}