games-emulation/mupen64plus-core: Fix GCC 10 / -fno-common
authorDavid Seifert <soap@gentoo.org>
Wed, 26 Feb 2020 14:33:58 +0000 (15:33 +0100)
committerDavid Seifert <soap@gentoo.org>
Wed, 26 Feb 2020 14:33:58 +0000 (15:33 +0100)
Closes: https://bugs.gentoo.org/708054
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
games-emulation/mupen64plus-core/files/mupen64plus-core-2.5.9-fix-gcc10-fno-common.patch [new file with mode: 0644]
games-emulation/mupen64plus-core/mupen64plus-core-2.5.9.ebuild

diff --git a/games-emulation/mupen64plus-core/files/mupen64plus-core-2.5.9-fix-gcc10-fno-common.patch b/games-emulation/mupen64plus-core/files/mupen64plus-core-2.5.9-fix-gcc10-fno-common.patch
new file mode 100644 (file)
index 0000000..cfc7d5a
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/src/device/r4300/idec.h
++++ b/src/device/r4300/idec.h
+@@ -82,6 +82,6 @@
+ #define IDEC_U53(r4300, iw, u53, u5) (void*)(((char*)(r4300)) + idec_u53((iw), (u53), (u5)))
+-const char* g_r4300_opcodes[R4300_OPCODES_COUNT];
++extern const char* g_r4300_opcodes[R4300_OPCODES_COUNT];
+ #endif
+--- a/src/main/workqueue.h
++++ b/src/main/workqueue.h
+@@ -27,7 +27,6 @@
+ struct work_struct;
+-struct work_struct *work;
+ typedef void (*work_func_t)(struct work_struct *work);
+ struct work_struct {
+     work_func_t func;
index f7e5603250c83427c9739742d1e453f800880582..5bf2f73d58f86dad8026e67187027defa3a5ba58 100644 (file)
@@ -33,6 +33,8 @@ DEPEND="${RDEPEND}
 REQUIRED_USE="gles2? ( !osd )"
 S=${WORKDIR}/${MY_P}
 
+PATCHES=( "${FILESDIR}"/${PN}-2.5.9-fix-gcc10-fno-common.patch )
+
 src_prepare() {
        default