dev-python/clang-python: Bump to 5.0.0
authorMichał Górny <mgorny@gentoo.org>
Fri, 8 Sep 2017 09:13:38 +0000 (11:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 8 Sep 2017 17:30:34 +0000 (19:30 +0200)
dev-python/clang-python/Manifest
dev-python/clang-python/clang-python-5.0.0.ebuild [new file with mode: 0644]

index 5bf7e7ecf9c43e01e78fb5703f1cee19849c1908..4d92e834aa5265d9fc54f2cf3a613a743367fa17 100644 (file)
@@ -1 +1,2 @@
 DIST cfe-4.0.1.src.tar.xz 10933628 SHA256 61738a735852c23c3bdbe52d035488cdb2083013f384d67c1ba36fabebd8769b SHA512 936c9e1626b27e63a4fb11f3c0cb998eeaf9a520ad6e2bcd67cb4352e59e7781ecc700df79794f3fd70473d90b7e2ba418a39038eb0146b68e843f0705c1f964 WHIRLPOOL 1cb56b36e21eab8004eec43d9c0f7377588cdbcd1d654cd0e6d836d43bc68dc0759993215439c1607e09ed3fa1f68b80504a222f73c1b76d3841cdf638dcbef2
+DIST cfe-5.0.0.src.tar.xz 11437024 SHA256 019f23c2192df793ac746595e94a403908749f8e0c484b403476d2611dd20970 SHA512 14acdd622310122b544c952ee5b932b7006d9d8424319f0e3974f2503d40a0cec4200fdd3d813a32ce0d877bcfbb9a5bd5c36f6142b4330e6c814f113ca2efe8 WHIRLPOOL 9d2fff35324621be191cc69b45db472681c9ebdf05aead09510f3178853ac8a179f2c454c2e6513e57f84a99980052671cd9a23d38d6d14b42dfda1853a7844a
diff --git a/dev-python/clang-python/clang-python-5.0.0.ebuild b/dev-python/clang-python/clang-python-5.0.0.ebuild
new file mode 100644 (file)
index 0000000..20a45b1
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI="https://releases.llvm.org/${PV/_//}/cfe-${PV/_/}.src.tar.xz"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+       >=sys-devel/clang-${PV}:*
+       !sys-devel/llvm:0[clang(-),python(-)]
+       !sys-devel/clang:0[python(-)]
+       ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/cfe-${PV/_/}.src/bindings/python
+
+src_prepare() {
+       default
+
+       # move to the correct subdirectory
+       # https://reviews.llvm.org/D37378
+       mv tests/{,cindex/}test_exception_specification_kind.py || die
+}
+
+src_test() {
+       python_foreach_impl nosetests -v || die
+}
+
+src_install() {
+       python_foreach_impl python_domodule clang
+}