dev-perl/Crypt-OpenSSL-Bignum: add libressl support
authorJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 14:32:38 +0000 (16:32 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 16:37:52 +0000 (18:37 +0200)
dev-perl/Crypt-OpenSSL-Bignum/Crypt-OpenSSL-Bignum-0.40.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Crypt-OpenSSL-Bignum/Crypt-OpenSSL-Bignum-0.40.0-r2.ebuild b/dev-perl/Crypt-OpenSSL-Bignum/Crypt-OpenSSL-Bignum-0.40.0-r2.ebuild
new file mode 100644 (file)
index 0000000..dee72d6
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=IROBERTS
+MODULE_VERSION=0.04
+inherit perl-module
+
+DESCRIPTION="OpenSSL's multiprecision integer arithmetic"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="libressl"
+
+RDEPEND="
+       !libressl? ( dev-libs/openssl:0 )
+       libressl? ( dev-libs/libressl )
+"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"