app-crypt/pius: bump to 3.0.0 and run test suite
authorNicholas Meyer <nickaristocrates@gmail.com>
Mon, 23 Mar 2020 15:58:40 +0000 (08:58 -0700)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 16 Apr 2020 06:50:57 +0000 (09:50 +0300)
Closes: https://bugs.gentoo.org/702762
Signed-off-by: Nicholas Meyer <nickaristocrates@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-crypt/pius/Manifest
app-crypt/pius/pius-3.0.0.ebuild [new file with mode: 0644]

index c18418a5b71888a4ad892e83ba9556f3565f36b5..177e05820905a445b1494429427ae93f436dabf7 100644 (file)
@@ -1 +1,2 @@
 DIST pius-2.2.4.tar.bz2 40578 BLAKE2B e7989631813658ff888c72b825269482ff33296abf0b9780ecb24df4628c499087a7591372ef96449b4899b1bcd730b0c75411bcd3c8839c57d3d4b5de374862 SHA512 3a178d30d98d0ed7ddf6819578a54ccfb9719f77c1f6385e3b254e28cd890817f328685c02cc464d4d592961c28ba314ca3175056b412dcdb301b851d874eb60
+DIST pius-3.0.0.tar.bz2 46643 BLAKE2B 18abe6a93bd719adf50fa4bcbf5128845d732b598d611e716a536f78f4930e6e63e7f60d7444775fbc32072935c13b1828377a9e843114255a4101f4e3199f98 SHA512 0c906574ac703f45e3318ae3e7994fe6580fd172849b2956d9084033d6fbfd69fec942b95bc2edadadc223fa0685ff0b9799ad03570b712b9cdb09d69491cc91
diff --git a/app-crypt/pius/pius-3.0.0.ebuild b/app-crypt/pius/pius-3.0.0.ebuild
new file mode 100644 (file)
index 0000000..98c97aa
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for signing and email all UIDs on a set of PGP keys"
+HOMEPAGE="https://www.phildev.net/pius/ https://github.com/jaymzh/pius"
+SRC_URI="https://github.com/jaymzh/pius/releases/download/v${PV}/pius-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=app-crypt/gnupg-2.0.0"
+RDEPEND="${DEPEND}
+       dev-lang/perl"
+
+python_test() {
+       ${EPYTHON} -m unittest discover -s test/* -v
+}