Version bump and new version of gentoo.completion which has limmited init.d support
authorChristian Birchinger <joker@gentoo.org>
Tue, 9 Sep 2003 23:08:19 +0000 (23:08 +0000)
committerChristian Birchinger <joker@gentoo.org>
Tue, 9 Sep 2003 23:08:19 +0000 (23:08 +0000)
app-shells/bash-completion/ChangeLog
app-shells/bash-completion/Manifest
app-shells/bash-completion/bash-completion-20030821.ebuild [new file with mode: 0644]
app-shells/bash-completion/files/digest-bash-completion-20030821 [new file with mode: 0644]
app-shells/bash-completion/files/gentoo.completion

index bdea187fd213b3fb8dc35de7e60ec4c1105cd1b7..b4b7871598dedf66c5bee796110d8642a6a53c16 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for app-shells/bash-completion
 # Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.37 2003/07/21 12:06:19 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.38 2003/09/09 23:08:13 joker Exp $
+
+*bash-completion-20030821 (10 Sep 2003)
+
+  10 Sep 2003; Christian Birchinger <joker@gentoo.org>
+  bash-completion-20030821.ebuild, files/gentoo.completion:
+  Version bump and new version of gentoo.completion which has
+  limmited init.d support
 
 *bash-completion-20030721 (21 Jul 2003)
 
index 3d78469cfb9fe62ef293ff38e2fb1b7b60a6b530..97548bb36995f91334e6759caa6270df8f509b03 100644 (file)
@@ -1,10 +1,12 @@
-MD5 85c90af82f4e00938e95fbbf7365bf1a ChangeLog 4486
+MD5 d097c80e6bbafabec32b52a64d805188 ChangeLog 4731
 MD5 822273ec32f2d50fd50a34a3e91fd585 bash-completion-20030505-r1.ebuild 1464
 MD5 404e3e265fe61db29a8d6557f018a9c9 bash-completion-20030713.ebuild 1466
 MD5 4e281359f4e0adb7356cab7bb57b4c5c bash-completion-20030721.ebuild 1466
+MD5 7672ca4c101564f634ebee46fee2fd08 bash-completion-20030821.ebuild 1466
 MD5 c85a85bd33aac22ae4872c85733e581f files/README.gentoo 491
 MD5 9b22241df7258cb9677cf9a1497e07c5 files/bash-completion 625
 MD5 86466a747ec82cd05ba511f06125c947 files/digest-bash-completion-20030505-r1 76
-MD5 58c57aafa06a6e59c9f607bd90f68dde files/gentoo.completion 14919
+MD5 3df1918a609a7b2fb8a30f9dd59f552f files/gentoo.completion 15096
 MD5 069e386b2f6e85a4b86d4929bfb1f585 files/digest-bash-completion-20030713 76
 MD5 60d3ff2b99d75697ce01c2ca72ade293 files/digest-bash-completion-20030721 76
+MD5 27ea6237a77a7e7edf98246e855b0a82 files/digest-bash-completion-20030821 76
diff --git a/app-shells/bash-completion/bash-completion-20030821.ebuild b/app-shells/bash-completion/bash-completion-20030821.ebuild
new file mode 100644 (file)
index 0000000..a7845ba
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20030821.ebuild,v 1.1 2003/09/09 23:08:13 joker Exp $
+
+S=${WORKDIR}/${PN/-/_}
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm ~amd64"
+
+DEPEND="sys-apps/tar
+       sys-apps/bzip2"
+
+RDEPEND=">=app-shells/bash-2.05a"
+
+src_install() {
+       insinto /etc
+       doins bash_completion
+
+       insinto /etc/bash_completion.d
+
+       doins contrib/unrar
+       doins contrib/harbour
+       doins contrib/isql
+       doins contrib/larch
+       doins contrib/lilypond
+       doins contrib/p4
+       doins contrib/ri
+
+       newins ${FILESDIR}/gentoo.completion gentoo
+
+       insinto /etc/profile.d
+       doins ${FILESDIR}/bash-completion
+
+       dodoc COPYING Changelog README
+}
+
+pkg_postinst() {
+       echo
+       einfo "Add the following line to your ~/.bashrc to"
+       einfo "activate completion support in your bash:"
+       einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+       echo
+
+       if [ -f /etc/bash_completion.d/gentoo.completion ]
+       then
+               echo
+               ewarn "The file 'gentoo.completion' in '/etc/bash_completion.d/' has been"
+               ewarn "replaced with 'gentoo'. Remove gentoo.completion to avoid problems."
+               echo
+       fi
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20030821 b/app-shells/bash-completion/files/digest-bash-completion-20030821
new file mode 100644 (file)
index 0000000..5a9dfd2
--- /dev/null
@@ -0,0 +1 @@
+MD5 62208abed378d4441d9cf5907dbe5129 bash-completion-20030821.tar.bz2 71045
index e1fcd56da758516f765ab24a33823cf2a081fd89..d3e5e32d83c352f5db98dab071dbb0d770fad4c5 100644 (file)
@@ -9,6 +9,13 @@
 # Author: Zach Forrest <zach@disinformation.ca>
 #
 
+#
+# simple completion for Gentoo style init
+#
+complete -W "start stop restart pause zap ineed needsme iuse usesme broken" \
+       $(for i in /etc/init.d/*; do echo ${i##*/}; done)
+
+
 #
 # emerge completion command
 #