media-plugins/kodi-visualization-goom: depend on media-libs/glm
authorCraig Andrews <candrews@gentoo.org>
Thu, 9 Apr 2020 15:44:26 +0000 (11:44 -0400)
committerCraig Andrews <candrews@gentoo.org>
Thu, 9 Apr 2020 15:46:30 +0000 (11:46 -0400)
Closes: https://bugs.gentoo.org/716746
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-plugins/kodi-visualization-goom/kodi-visualization-goom-2.2.1-r1.ebuild [new file with mode: 0644]
media-plugins/kodi-visualization-goom/kodi-visualization-goom-9999.ebuild

diff --git a/media-plugins/kodi-visualization-goom/kodi-visualization-goom-2.2.1-r1.ebuild b/media-plugins/kodi-visualization-goom/kodi-visualization-goom-2.2.1-r1.ebuild
new file mode 100644 (file)
index 0000000..97a386c
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Goom visualizer for Kodi"
+HOMEPAGE="https://github.com/notspiff/visualization.goom"
+SRC_URI=""
+
+case ${PV} in
+9999)
+       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/notspiff/visualization.goom.git"
+       inherit git-r3
+       ;;
+*)
+       KEYWORDS="~amd64 ~x86"
+       CODENAME="Leia"
+       SRC_URI="https://github.com/notspiff/visualization.goom/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/visualization.goom-${PV}-${CODENAME}"
+       ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       media-libs/glm
+       =media-tv/kodi-18*
+       virtual/opengl
+       "
+
+RDEPEND="
+       ${DEPEND}
+       "
index 7e0565f13e2cd88c0b2bdf288088755d629902f3..39f82f9aaa113558b26f72f95aadc89928184b20 100644 (file)
@@ -28,6 +28,7 @@ SLOT="0"
 IUSE=""
 
 DEPEND="
+       media-libs/glm
        ~media-tv/kodi-9999
        virtual/opengl
        "