sys-apps/util-linux: Synced live ebuild.
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 3 Jul 2019 11:10:21 +0000 (13:10 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 3 Jul 2019 14:03:47 +0000 (16:03 +0200)
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/util-linux/util-linux-9999.ebuild

index ef3a8b6b3247256f2b9d0c0ae1c725f2549338b7..89fd6458e7b2c7d8c7f27140ae3a788aac489a23 100644 (file)
@@ -247,12 +247,13 @@ python_install() {
 }
 
 multilib_src_install() {
-       emake DESTDIR="${D}" install
-
        if multilib_is_native_abi && use python; then
                python_foreach_impl python_install
        fi
 
+       # This needs to be called AFTER python_install call (#689190)
+       emake DESTDIR="${D}" install
+
        if multilib_is_native_abi && use userland_GNU; then
                # need the libs in /
                gen_usr_ldscript -a blkid fdisk mount smartcols uuid