net-libs/webkit-gtk: Add upstream patch to fix build against ICU-65
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 29 Oct 2019 19:03:19 +0000 (20:03 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 29 Oct 2019 22:21:34 +0000 (23:21 +0100)
https://bugs.webkit.org/show_bug.cgi?id=202600

Acked-by: Mart Raudsepp <leio@gentoo.org>
Closes: https://bugs.gentoo.org/698596
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-libs/webkit-gtk/files/webkit-gtk-2.24.4-icu-65.patch [new file with mode: 0644]
net-libs/webkit-gtk/webkit-gtk-2.24.4.ebuild

diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.24.4-icu-65.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.24.4-icu-65.patch
new file mode 100644 (file)
index 0000000..475c985
--- /dev/null
@@ -0,0 +1,53 @@
+From 9b60e834454dc93f46f05b1cfdc0aad0c6b7de97 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Fri, 4 Oct 2019 22:17:11 +0200
+Subject: [PATCH] Add missing semicolons to fix build with icu 65.1
+
+---
+ Source/WTF/wtf/URLHelpers.cpp   |  2 +-
+ Source/WebCore/dom/Document.cpp |  6 +++---
+ 4 files changed, 25 insertions(+), 4 deletions(-)
+
+diff --git a/Source/WTF/wtf/URLHelpers.cpp b/Source/WTF/wtf/URLHelpers.cpp
+index 18e7f13cd61..c584f1a0cb7 100644
+--- a/Source/WTF/wtf/URLHelpers.cpp
++++ b/Source/WTF/wtf/URLHelpers.cpp
+@@ -301,7 +301,7 @@ static bool allCharactersInIDNScriptWhiteList(const UChar* buffer, int32_t lengt
+     Optional<UChar32> previousCodePoint;
+     while (i < length) {
+         UChar32 c;
+-        U16_NEXT(buffer, i, length, c)
++        U16_NEXT(buffer, i, length, c);
+         UErrorCode error = U_ZERO_ERROR;
+         UScriptCode script = uscript_getScript(c, &error);
+         if (error != U_ZERO_ERROR) {
+diff --git a/Source/WebCore/dom/Document.cpp b/Source/WebCore/dom/Document.cpp
+index 0fd0fa090bf..01f76850f3d 100644
+--- a/Source/WebCore/dom/Document.cpp
++++ b/Source/WebCore/dom/Document.cpp
+@@ -4954,12 +4954,12 @@ static bool isValidNameNonASCII(const UChar* characters, unsigned length)
+     unsigned i = 0;
+     UChar32 c;
+-    U16_NEXT(characters, i, length, c)
++    U16_NEXT(characters, i, length, c);
+     if (!isValidNameStart(c))
+         return false;
+     while (i < length) {
+-        U16_NEXT(characters, i, length, c)
++        U16_NEXT(characters, i, length, c);
+         if (!isValidNamePart(c))
+             return false;
+     }
+@@ -5019,7 +5019,7 @@ ExceptionOr<std::pair<AtomString, AtomString>> Document::parseQualifiedName(cons
+     for (unsigned i = 0; i < length; ) {
+         UChar32 c;
+-        U16_NEXT(qualifiedName, i, length, c)
++        U16_NEXT(qualifiedName, i, length, c);
+         if (c == ':') {
+             if (sawColon)
+                 return Exception { InvalidCharacterError };
+-- 
+2.23.0
index f8ed8e6fec93a145c6060ae572574c4ba5a65376..d90cc8c26a4813947477011bb24fa8e500c8da97 100644 (file)
@@ -159,6 +159,7 @@ pkg_setup() {
 }
 
 src_prepare() {
+       eapply "${FILESDIR}/${P}-icu-65.patch" # bug 698596
        cmake-utils_src_prepare
        gnome2_src_prepare
 }