dev-python/google-pasta: bump 0.1.7
authorJason Zaman <perfinion@gentoo.org>
Mon, 17 Jun 2019 08:52:44 +0000 (16:52 +0800)
committerJason Zaman <perfinion@gentoo.org>
Wed, 19 Jun 2019 02:41:03 +0000 (10:41 +0800)
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-python/google-pasta/Manifest
dev-python/google-pasta/google-pasta-0.1.7.ebuild [new file with mode: 0644]

index 45196c890c6644f8d253e533c0c0d5835d0e30da..9b40c0a89da6aa6b188ca338350e88155d12ff95 100644 (file)
@@ -1 +1,2 @@
 DIST google-pasta-0.1.1.tar.gz 34476 BLAKE2B 04de1237eda9449e4648af0fc43b538d4c71f43b1205fbb531981c773266e404d9673adc9f7c3e74706b90993cae31d7a2c812c3ee5a02edce6ce669491f2823 SHA512 94a5016acbba72261ccd488f788b23934651149c7d763aed4f998018bdbf299261fe125accb1359f70d024c3bc3db0f1279e5e780e1e4b87b328f2c473a1b003
+DIST google-pasta-0.1.7.tar.gz 37090 BLAKE2B 55d1846a733d3d593e0df16f360a55879b7d5c88a1df410b2f86e97dbcdb01493a7abaebfa57f0f39cbe0dbd081847bce41d8862dea30cdef65d745870ffd89c SHA512 dd374fd039b7b6bd5ca9821dc8342854277cdd7b58738532cf0a39458c3021a1d5011f147c5a3fd1936023da7890636a65d4026af7da65194bde0004ec0caa35
diff --git a/dev-python/google-pasta/google-pasta-0.1.7.ebuild b/dev-python/google-pasta/google-pasta-0.1.7.ebuild
new file mode 100644 (file)
index 0000000..6baf55a
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python{3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="AST-based Python refactoring library"
+HOMEPAGE="https://pypi.org/project/google-pasta/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"