Version bump to 6.37 and 7.39 to address DRUPAL-SA-CORE-2015-003 - fixes bug 558330.
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Sat, 22 Aug 2015 13:31:06 +0000 (13:31 +0000)
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Sat, 22 Aug 2015 13:31:53 +0000 (13:31 +0000)
Bump to the latest 8.0.0 beta and update postinstall to point to the Wiki.

Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
www-apps/drupal/Manifest
www-apps/drupal/drupal-6.37.ebuild [moved from www-apps/drupal/drupal-6.36.ebuild with 100% similarity]
www-apps/drupal/drupal-7.39.ebuild [moved from www-apps/drupal/drupal-7.38.ebuild with 100% similarity]
www-apps/drupal/drupal-8.0.0_beta14.ebuild [new file with mode: 0644]
www-apps/drupal/files/postinstall-en.txt

index 8c8faab4cabcd17c06ff3a1e40d25a8399783437..e0515da66a199b6dd7adee49e2a7f20f0a14ce89 100644 (file)
@@ -1,3 +1,4 @@
-DIST drupal-6.36.tar.gz 1112226 SHA256 e70fc70c7bb268e262bfa57d265dcc4c88daf17e918619d607aaac7285d22ac4 SHA512 ec2ed0875e53291388567de2cc75f20cda0e1dbb14c2f355832053f94275a161db2a1f4b96536f8c71fa2f8547400c924f62e3c326a93d8f58f7dc6bc7bb39ce WHIRLPOOL 260e44bc69fdb02a1e9fb20760fc77d6bf29320a6ce823b7fd0f970554420ad564765c4f153088363c3846699b4e7deae1f024e300280a53de23a81a69bfbf55
-DIST drupal-7.38.tar.gz 3247864 SHA256 dccf3f12135183e94baaf960ce0993ad99c47afefe830b193cd30a17a317853e SHA512 b36399283aa370dc325e0d2cf3f2ed7615f6996ee43c79e3cba2c8ecc62a01b59211f24b56dda8f420cac2caa1bb9212f65158abc11c27d5c0b0a345f386cbeb WHIRLPOOL f678adfba1e63d35539e76dd24d9e680ae85958126a5694a7402be7fe8081a91990755ea71a35322b4c175493ecd7914071741155f119b29c2296f2821a6dcca
+DIST drupal-6.37.tar.gz 1112775 SHA256 e3db44fdeefa9c4b3edf31816a8cfcaffe300986dbebdc22769ec739d3296d5d SHA512 4895221c7fb2913618490722629888a4862f28633a49ba5363a0393974941c68d07a3e255d6f380d7d97d0aa3251a76c03d5d0f0ab4c968af301a1207d8d35a0 WHIRLPOOL 8d7a0576fba31f2fcf9035755d3ef9a521461d9b3dfab57eb8871fe66038f4056b690a84513bf61a639b4c5f8126fa5180734542b0036f5d089afb0cb2abfecd
+DIST drupal-7.39.tar.gz 3249343 SHA256 afad72be4389e2a2dfc630fc8582277ed185d884101978890139e0d14e4ddbab SHA512 5884ec66eac5340272201d524e7346e9bb92772c5451d9d47571e7ba8aac11d3533dabfdbba32339e7fdc691efa6fd22bbb4137633e337f148a2bd0678d3b65e WHIRLPOOL d2b6fc6e481f8c5966d0ad226fe423851e5c9d91f53283e934903e882485a0a04cbe442aa102424fc8eb9eb9303650aec8db6396b3e8bd7fccd68fb1c2eff25d
 DIST drupal-8.0.0-beta11.tar.gz 10500627 SHA256 0c7a6b84dc6019bc5afcf3066aa9c2a8a5cd4147a03d48314728156cc434bda1 SHA512 bdcac51cb8379711245d7e15a3bc879634c6c88af6799525f7dda3cd5be799193a3e4151d902569f9f008d89f309f7bca2180ebca4cb1f21bce87ac744461748 WHIRLPOOL 44b1a8670c5dfbf9d5208e5c5dc75a3e4c4a674befa1bd64b10409989d72da01e8e0420d9dc1e7d39b633fa49b80166c0e812f2deeb13304f4850fc777e1b36b
+DIST drupal-8.0.0-beta14.tar.gz 10493263 SHA256 0dc8e4c9b3ed2f4f9f50741a6d014278d85d98abea3d71a9936b46c2b8249978 SHA512 09a0c718519518a2536a1b72fbb5c79ee4a63fa453d9669539e87f5c70b9cbb43c42c433174dccd1bcf920a22e7766ca30df88663d6356c709ad958dcd8e968a WHIRLPOOL 62cdae3ed75fd383bca76a9c64a081d0c0a12e7591f2acbd568bf3de00ca7b1e7ffa2fdc126f625dbf07cc88d42f50b9d16b5a6d572b5afe1a8d8616a395b610
diff --git a/www-apps/drupal/drupal-8.0.0_beta14.ebuild b/www-apps/drupal/drupal-8.0.0_beta14.ebuild
new file mode 100644 (file)
index 0000000..ca6797a
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="http://drupal.org/"
+SRC_URI="http://drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+       dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+       virtual/httpd-php
+       accelerator? ( ||
+               (
+                       dev-php/xcache
+                       (
+                               >=dev-lang/php-5.5[opcache]
+                               dev-php/pecl-apcu
+                       )
+               )
+       )
+       uploadprogress? ( dev-php/pecl-uploadprogress )
+       mysql? (
+               || (
+                       dev-lang/php[mysql]
+                       dev-lang/php[mysqli]
+               )
+       )
+       sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+       webapp_src_preinst
+
+       local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+               core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPGRADE.txt "
+
+       dodoc ${docs}
+       rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+       cp sites/default/{default.settings.php,settings.php} || die
+       insinto "${MY_HTDOCSDIR}"
+       doins -r .
+
+       dodir "${MY_HTDOCSDIR}"/files
+       webapp_serverowned "${MY_HTDOCSDIR}"/files
+       webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+       webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+       webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+       webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+       webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+       webapp_src_install
+}
+
+pkg_postinst() {
+       echo
+       ewarn "SECURITY NOTICE"
+       ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+       ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+       echo
+       ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+       ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+       echo
+       ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+       ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+       ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+       ewarn "reported by the setup."
+       echo
+}
index aca91ecdac2d26de21043bfd02c06144ecfe7a66..a8a59c184b5a3dbe4b2de52a96bc767e922beaf5 100644 (file)
@@ -4,7 +4,7 @@ This assumes you have some knowledge of MySQL, and already have it
 installed and configured. If not, please refer to the Gentoo MySQL
 guide at the following URL:
 
-http://www.gentoo.org/doc/en/mysql-howto.xml 
+https://wiki.gentoo.org/wiki/MySQL/Startup_Guide
 
 Once you have a database ready all you need to do is to go to this 
 location