sys-kernel/linux-firmware: drop old
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 29 Oct 2018 23:06:00 +0000 (00:06 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 29 Oct 2018 23:06:17 +0000 (00:06 +0100)
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-kernel/linux-firmware/Manifest
sys-kernel/linux-firmware/linux-firmware-20180825.ebuild [deleted file]
sys-kernel/linux-firmware/linux-firmware-20181001.ebuild [deleted file]

index 6f37da8e9a8ce9d009c12479e236710b6c3e9e7e..a3a4e3036262333d5ae1ac1e3e23d76bfef8579d 100644 (file)
@@ -1,3 +1 @@
-DIST linux-firmware-20180825.tar.gz 156618714 BLAKE2B 1bf44c456a87dce2e0622c8ef80bacae9d1aa76efacbb1519718be4a2c3e36a72b8baced8dc17953515052be923b85a8368179dfad591fbc7402521bce564e20 SHA512 583623fedf18a987a20cb6f5337146131a7b17a95ee79cb4b35199b6ecf42af039b824623235501685db18839c0d7e9e81cd79ed47fb993b4e72346bf9159021
-DIST linux-firmware-20181001.tar.gz 158397569 BLAKE2B 2694014f847fb60f5f0c208a479f4cdf0b422ef249735f22f0ef72e0fd385e8ba6737da1b1cf24daf74fd5f28c3c69b96e14850520f16b8a556c7ca734a3557e SHA512 f20b65122381423597cebd5a3018bbe55f0f8697a03b5ae3e7c1c6dd1cddcb1da4f3fddc8e4accb2d780faf1c0e66bed7dda6b1ab1c48d2e0b2435a5a7eb03f7
 DIST linux-firmware-20181026.tar.gz 167486645 BLAKE2B 9923b9a8ab692023022d7bceb238b2ec4eba395062307864be558d969fba657301ada317b95071cad82a7a883a2d08f63f0ed34ecc7914a36f31ce85f55ac31f SHA512 4d6eff765557888dea432e0a28973c8ec067354a57aa4c37198e887618ca17e9d5e1243a618820fb470a86a5ce4b6255290f1c2c3835baba4fb87148372cafb0
diff --git a/sys-kernel/linux-firmware/linux-firmware-20180825.ebuild b/sys-kernel/linux-firmware/linux-firmware-20180825.ebuild
deleted file mode 100644 (file)
index 3a8fcad..0000000
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-inherit savedconfig
-
-if [[ ${PV} == 99999999* ]]; then
-       inherit git-r3
-       SRC_URI=""
-       EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
-else
-       GIT_COMMIT="fea76a04f25fd0a217c0d566ff5ff8f23ad3e648"
-       SRC_URI="https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="alpha amd64 arm arm64 hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-fi
-
-DESCRIPTION="Linux firmware files"
-HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git"
-
-LICENSE="linux-firmware ( BSD ISC MIT no-source-code ) GPL-2 GPL-2+ freedist"
-SLOT="0"
-IUSE="savedconfig"
-
-DEPEND=""
-RDEPEND="!savedconfig? (
-               !sys-firmware/alsa-firmware[alsa_cards_ca0132]
-               !sys-firmware/alsa-firmware[alsa_cards_korg1212]
-               !sys-firmware/alsa-firmware[alsa_cards_maestro3]
-               !sys-firmware/alsa-firmware[alsa_cards_sb16]
-               !sys-firmware/alsa-firmware[alsa_cards_ymfpci]
-               !media-tv/cx18-firmware
-               !<sys-firmware/ivtv-firmware-20080701-r1
-               !media-tv/linuxtv-dvb-firmware[dvb_cards_cx231xx]
-               !media-tv/linuxtv-dvb-firmware[dvb_cards_cx23885]
-               !media-tv/linuxtv-dvb-firmware[dvb_cards_usb-dib0700]
-               !net-dialup/ueagle-atm
-               !net-dialup/ueagle4-atm
-               !net-wireless/ar9271-firmware
-               !net-wireless/i2400m-fw
-               !net-wireless/libertas-firmware
-               !sys-firmware/rt61-firmware
-               !net-wireless/rt73-firmware
-               !net-wireless/rt2860-firmware
-               !net-wireless/rt2870-firmware
-               !sys-block/qla-fc-firmware
-               !sys-firmware/amd-ucode
-               !sys-firmware/iwl1000-ucode
-               !sys-firmware/iwl2000-ucode
-               !sys-firmware/iwl2030-ucode
-               !sys-firmware/iwl3945-ucode
-               !sys-firmware/iwl4965-ucode
-               !sys-firmware/iwl5000-ucode
-               !sys-firmware/iwl5150-ucode
-               !sys-firmware/iwl6000-ucode
-               !sys-firmware/iwl6005-ucode
-               !sys-firmware/iwl6030-ucode
-               !sys-firmware/iwl6050-ucode
-               !sys-firmware/iwl3160-ucode
-               !sys-firmware/iwl7260-ucode
-               !sys-firmware/iwl7265-ucode
-               !sys-firmware/iwl3160-7260-bt-ucode
-               !sys-firmware/radeon-ucode
-       )"
-#add anything else that collides to this
-
-RESTRICT="binchecks strip"
-
-src_unpack() {
-       if [[ ${PV} == 99999999* ]]; then
-               git-r3_src_unpack
-       else
-               default
-               # rename directory from git snapshot tarball
-               mv ${PN}-*/ ${P} || die
-       fi
-}
-
-src_prepare() {
-       default
-
-       echo "# Remove files that shall not be installed from this list." > ${PN}.conf
-       find * \( \! -type d -and \! -name ${PN}.conf \) >> ${PN}.conf
-
-       if use savedconfig; then
-               restore_config ${PN}.conf
-               ebegin "Removing all files not listed in config"
-               find * \( \! -type d -and \! -name ${PN}.conf \) \
-                       | sort ${PN}.conf ${PN}.conf - \
-                       | uniq -u | xargs -r rm
-               eend $? || die
-               # remove empty directories, bug #396073
-               find -type d -empty -delete || die
-       fi
-}
-
-src_install() {
-       if use !savedconfig; then
-               save_config ${PN}.conf
-       fi
-       rm ${PN}.conf || die
-       insinto /lib/firmware/
-       doins -r *
-}
-
-pkg_preinst() {
-       if use savedconfig; then
-               ewarn "USE=savedconfig is active. You must handle file collisions manually."
-       fi
-}
-
-pkg_postinst() {
-       elog "If you are only interested in particular firmware files, edit the saved"
-       elog "configfile and remove those that you do not want."
-}
diff --git a/sys-kernel/linux-firmware/linux-firmware-20181001.ebuild b/sys-kernel/linux-firmware/linux-firmware-20181001.ebuild
deleted file mode 100644 (file)
index f095154..0000000
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-inherit savedconfig
-
-if [[ ${PV} == 99999999* ]]; then
-       inherit git-r3
-       SRC_URI=""
-       EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
-else
-       GIT_COMMIT="7c81f23ad903f72e87e2102d8f52408305c0f7a2"
-       SRC_URI="https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="alpha amd64 arm arm64 hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-fi
-
-DESCRIPTION="Linux firmware files"
-HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git"
-
-LICENSE="linux-firmware ( BSD ISC MIT no-source-code ) GPL-2 GPL-2+ freedist"
-SLOT="0"
-IUSE="savedconfig"
-
-DEPEND=""
-RDEPEND="!savedconfig? (
-               !sys-firmware/alsa-firmware[alsa_cards_ca0132]
-               !sys-firmware/alsa-firmware[alsa_cards_korg1212]
-               !sys-firmware/alsa-firmware[alsa_cards_maestro3]
-               !sys-firmware/alsa-firmware[alsa_cards_sb16]
-               !sys-firmware/alsa-firmware[alsa_cards_ymfpci]
-               !media-tv/cx18-firmware
-               !<sys-firmware/ivtv-firmware-20080701-r1
-               !media-tv/linuxtv-dvb-firmware[dvb_cards_cx231xx]
-               !media-tv/linuxtv-dvb-firmware[dvb_cards_cx23885]
-               !media-tv/linuxtv-dvb-firmware[dvb_cards_usb-dib0700]
-               !net-dialup/ueagle-atm
-               !net-dialup/ueagle4-atm
-               !net-wireless/ar9271-firmware
-               !net-wireless/i2400m-fw
-               !net-wireless/libertas-firmware
-               !sys-firmware/rt61-firmware
-               !net-wireless/rt73-firmware
-               !net-wireless/rt2860-firmware
-               !net-wireless/rt2870-firmware
-               !sys-block/qla-fc-firmware
-               !sys-firmware/amd-ucode
-               !sys-firmware/iwl1000-ucode
-               !sys-firmware/iwl2000-ucode
-               !sys-firmware/iwl2030-ucode
-               !sys-firmware/iwl3945-ucode
-               !sys-firmware/iwl4965-ucode
-               !sys-firmware/iwl5000-ucode
-               !sys-firmware/iwl5150-ucode
-               !sys-firmware/iwl6000-ucode
-               !sys-firmware/iwl6005-ucode
-               !sys-firmware/iwl6030-ucode
-               !sys-firmware/iwl6050-ucode
-               !sys-firmware/iwl3160-ucode
-               !sys-firmware/iwl7260-ucode
-               !sys-firmware/iwl7265-ucode
-               !sys-firmware/iwl3160-7260-bt-ucode
-               !sys-firmware/radeon-ucode
-       )"
-#add anything else that collides to this
-
-RESTRICT="binchecks strip"
-
-src_unpack() {
-       if [[ ${PV} == 99999999* ]]; then
-               git-r3_src_unpack
-       else
-               default
-               # rename directory from git snapshot tarball
-               mv ${PN}-*/ ${P} || die
-       fi
-}
-
-src_prepare() {
-       default
-
-       echo "# Remove files that shall not be installed from this list." > ${PN}.conf
-       find * \( \! -type d -and \! -name ${PN}.conf \) >> ${PN}.conf
-
-       if use savedconfig; then
-               restore_config ${PN}.conf
-               ebegin "Removing all files not listed in config"
-               find * \( \! -type d -and \! -name ${PN}.conf \) \
-                       | sort ${PN}.conf ${PN}.conf - \
-                       | uniq -u | xargs -r rm
-               eend $? || die
-               # remove empty directories, bug #396073
-               find -type d -empty -delete || die
-       fi
-}
-
-src_install() {
-       if use !savedconfig; then
-               save_config ${PN}.conf
-       fi
-       rm ${PN}.conf || die
-       insinto /lib/firmware/
-       doins -r *
-}
-
-pkg_preinst() {
-       if use savedconfig; then
-               ewarn "USE=savedconfig is active. You must handle file collisions manually."
-       fi
-}
-
-pkg_postinst() {
-       elog "If you are only interested in particular firmware files, edit the saved"
-       elog "configfile and remove those that you do not want."
-}