app-pda/jpilot: Fix paths with plugins on newest profile.
authorgryf <gryf73@gmail.com>
Sun, 15 Dec 2019 08:01:17 +0000 (10:01 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 15 Dec 2019 08:05:58 +0000 (10:05 +0200)
Closes: https://bugs.gentoo.org/688098
Signed-off-by: Roman Dobosz <gryf73@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-pda/jpilot/jpilot-1.8.2-r1.ebuild [new file with mode: 0644]

diff --git a/app-pda/jpilot/jpilot-1.8.2-r1.ebuild b/app-pda/jpilot/jpilot-1.8.2-r1.ebuild
new file mode 100644 (file)
index 0000000..7938cdb
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
+HOMEPAGE="http://www.jpilot.org/"
+SRC_URI="http://jpilot.org/tarballs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 x86"
+IUSE="nls"
+
+RDEPEND="
+       app-pda/pilot-link
+       dev-libs/libgcrypt:0=
+       x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+       nls? (
+               dev-util/intltool
+               sys-devel/gettext
+       )
+       virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.8.2-qa-desktop-file.patch
+       "${FILESDIR}"/${PN}-1.8.2-fix-paths.patch
+)
+
+src_prepare() {
+       default
+       sed -i -e 's|_UNQUOTED(ABILIB, "lib"|_UNQUOTED(ABILIB, "'$(get_libdir)'"|' configure.in || die
+       mv configure.{in,ac} || die
+       eautoreconf
+}
+
+src_configure() {
+       econf $(use_enable nls)
+}
+
+src_install() {
+       default
+       docompress -x /usr/share/doc/${PF}/icons
+
+       # .la files for plugins are useless
+       find "${D}" -name '*.la' -delete || die
+}