dev-ml/ocaml-gettext: Bump to 0.3.7
authorAlexis Ballier <aballier@gentoo.org>
Tue, 14 Mar 2017 09:44:42 +0000 (10:44 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 14 Mar 2017 10:21:23 +0000 (11:21 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2

dev-ml/ocaml-gettext/Manifest
dev-ml/ocaml-gettext/ocaml-gettext-0.3.7.ebuild [new file with mode: 0644]

index 5c0827b30edc127da0c6f9653645f7113b8d5d98..0bcde2cd1d289ad700405765e3f3f3f2c0614d0c 100644 (file)
@@ -1 +1,2 @@
 DIST ocaml-gettext-0.3.5.tar.gz 165238 SHA256 d19484ba7e14d078c85da66cba1eb28ed0cdc92c84db45e6dfb8f7e40f2cc268 SHA512 a60d51c09dad3076415ef24a9bb3121f84ad649d7a9fa1b9a7da719dd385e4ed7cd9ffbabefbade7ea0daf7b0a5a5eb71b1d0ed21b369914b49f66d0d918c446 WHIRLPOOL b638ecfe765e673408ced9e4ee0467029b7a7dbf0dfff826c45471b0cea2c26765db9b833d261be325abf5579e90ab0f669fac2a1cd7682e26d49a2fc277e5f0
+DIST ocaml-gettext-0.3.7.tar.gz 134316 SHA256 82f99289cb3c7ac5d1a410f74678b3b22444e1b136090bae1fff1e09fe0856aa SHA512 1358320359b9d2f3fd97a47d69b2a619942a65605c1e5cbf25e33ef42a10273167b526bca15e6c9523b87d8ea9dfd3215334050ad8eb84a8c41d4feef880a27a WHIRLPOOL 4290a2d30e7bdc3a6c95fdd79d3de7b5994d7f8583894abafee9ea9abc7041c772f0abf934de53b05e1cfeb9f8e712a07b9141ab17521221bf568db168f19d35
diff --git a/dev-ml/ocaml-gettext/ocaml-gettext-0.3.7.ebuild b/dev-ml/ocaml-gettext/ocaml-gettext-0.3.7.ebuild
new file mode 100644 (file)
index 0000000..90649dc
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils autotools
+
+DESCRIPTION="Provides support for internationalization of OCaml program"
+HOMEPAGE="https://github.com/gildor478/ocaml-gettext"
+SRC_URI="https://github.com/gildor478/ocaml-gettext/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-lang/ocaml-3.12.1:=
+       >=dev-ml/ocaml-fileutils-0.4.0:=
+       >=dev-ml/camomile-0.8.3:=
+       sys-devel/gettext
+       dev-ml/camlp4:=
+       "
+DEPEND="${RDEPEND}
+       doc? ( app-text/docbook-xsl-stylesheets dev-libs/libxslt )
+       test? ( dev-ml/ounit )"
+
+src_prepare() {
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --with-docbook-stylesheet="${EPREFIX}/usr/share/sgml/docbook/xsl-stylesheets/" \
+               $(use_enable doc) \
+               $(use_enable test)
+}
+
+src_compile() {
+       emake -j1
+}
+
+src_install() {
+       findlib_src_preinst
+       emake -j1 DESTDIR="${D}" \
+               BINDIR="${ED}/usr/bin" \
+               PODIR="${ED}/usr/share/locale/" \
+               DOCDIR="${ED}/usr/share/doc/${PF}" \
+               MANDIR="${ED}/usr/share/man" \
+               install
+       dodoc CHANGELOG README THANKS TODO
+}