dev-python/oauth2: Drop unnecessary die
authorJustin Lecher <jlec@gentoo.org>
Fri, 11 Sep 2015 07:03:46 +0000 (09:03 +0200)
committerJustin Lecher <jlec@gentoo.org>
Fri, 11 Sep 2015 07:53:16 +0000 (09:53 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/oauth2/oauth2-1.5.211-r1.ebuild

index df5026acce51a0bfdf8795e2c8a86021b3341d1a..37766bc5ff9a88154f2c834cfa3562609217ae19 100644 (file)
@@ -3,6 +3,7 @@
 # $Id$
 
 EAPI=5
+
 PYTHON_COMPAT=( python2_7 pypy )
 
 inherit distutils-r1
@@ -17,7 +18,8 @@ KEYWORDS="amd64 x86 ~x64-macos"
 IUSE="test"
 
 RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( ${RDEPEND}
                dev-python/coverage[${PYTHON_USEDEP}]
                dev-python/mock[${PYTHON_USEDEP}]
@@ -26,5 +28,5 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
 PATCHES=( "${FILESDIR}/${PN}-exclude-tests.patch" )
 
 python_test() {
-       esetup.py test || die "Tests fail with ${EPYTHON}"
+       esetup.py test
 }