sys-libs/libxcrypt-4.4.16: version bump
authorPatrick McLean <chutzpah@gentoo.org>
Sat, 11 Apr 2020 19:01:17 +0000 (12:01 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Sat, 11 Apr 2020 19:03:04 +0000 (12:03 -0700)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
sys-libs/libxcrypt/Manifest
sys-libs/libxcrypt/libxcrypt-4.4.16.ebuild [new file with mode: 0644]

index ee51b237512087d8cc987b158a1af1210a7e6fe1..344c0f505e9dc101d7c9058640c6bc77a597cfc3 100644 (file)
@@ -1,3 +1,4 @@
 DIST libxcrypt-4.4.10.tar.gz 499736 BLAKE2B 32da99488c21a21c3310a735a08a70002a3a56d7d9d4a9fd0c16436ef2b42ee8a9b877c5b5dcbf1bc9a38fbef3370d5ff4585167ff25025f854ccd020014dcd4 SHA512 fd714542dad40db721c03270b5a03e2c068b0750e887dcac4c651433d5905d08bd5c5db3762cc2e4ceee0103bd62810559ea197d164126169e0b253675415ca2
 DIST libxcrypt-4.4.12.tar.gz 493620 BLAKE2B 185cc9a0b9f573801e75bf2ffb3eaa578016804d175443a53b2cef01334acb6f8fa5a0fe72e346ff368e3db355338b1f1dbd00e93828dde2594f0adee3753f69 SHA512 945dfd307ebd3d1b3dd9f22057b23b651c0ffaab55bf4151950565a3f0fea8b0e2bc2886318ceea707985d720e83e8663e4590bc72e91f470bae3a98f41ab30f
+DIST libxcrypt-4.4.16.tar.gz 480694 BLAKE2B 0e93c2ff45a8148f82a80a67fb732a3ef42e87505d19258023f91d3352a382483204e77e2704e7a0de15f4f1e38a326d0867506a5580faf8c81857270588a4a3 SHA512 e1d3b1262c6be7c6c8847b8c4eb8191d9e5e482798be6f1186876c72f3d8c737124378ec45a38aa464f556e10a557b96f855bd371f03c3611eada27904bf6781
 DIST libxcrypt_2.4.orig.tar.gz 361503 BLAKE2B 6347bea4b22ae7742cb516a0a8673bbd7c37f645b2dbb383f4c4a6bbcc95a12897068ab7354fa015bbb65f6dc331b95ce24b48aa4bdd7a57433d8f5bc245392d SHA512 7171ce1b5b7f949232c4db94cf98bdd6396c3e2a8f2f483c041cab92d752e3a2fa93d564ede7efece57c069df129e6cc03049cf3e3f07bd3556031a7c4197cbf
diff --git a/sys-libs/libxcrypt/libxcrypt-4.4.16.ebuild b/sys-libs/libxcrypt/libxcrypt-4.4.16.ebuild
new file mode 100644 (file)
index 0000000..166f638
--- /dev/null
@@ -0,0 +1,163 @@
+# Copyright 2004-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit autotools multibuild python-any-r1 multilib-minimal
+
+DESCRIPTION="Extended crypt library for descrypt, md5crypt, bcrypt, and others "
+SRC_URI="https://github.com/besser82/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/besser82/libxcrypt"
+
+LICENSE="LGPL-2.1+ public-domain BSD BSD-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compat split-usr +static-libs system test"
+
+DEPEND="system? (
+               elibc_glibc? ( sys-libs/glibc[-crypt(+)] )
+               !sys-libs/musl
+       )"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-apps/findutils
+       test? ( $(python_gen_any_dep 'dev-python/passlib[${PYTHON_USEDEP}]') )"
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="split-usr? ( system )"
+
+PATCHES=(
+       "${FILESDIR}/libxcrypt-4.4.12-pythonver.patch"
+       "${FILESDIR}/libxcrypt-4.4.12-multibuild.patch"
+)
+
+python_check_deps() {
+       has_version -b "dev-python/passlib[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+       MULTIBUILD_VARIANTS=(
+               $(usex compat 'xcrypt_compat' '')
+               xcrypt_nocompat
+       )
+
+       use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       multibuild_foreach_variant multilib-minimal_src_configure
+}
+
+get_xclibdir() {
+       printf -- "%s/%s/%s\n" \
+               "$(usex split-usr '' '/usr')" \
+               "$(get_libdir)" \
+               "$(usex system '' 'xcrypt')"
+}
+
+multilib_src_configure() {
+       local -a myconf=(
+               --libdir=$(get_xclibdir)
+               --with-pkgconfigdir=/usr/$(get_libdir)/pkgconfig
+               --includedir="${EPREFIX}/usr/include/$(usex system '' 'xcrypt')"
+       )
+
+       case "${MULTIBUILD_ID}" in
+               xcrypt_compat-*)
+                       myconf+=(
+                               --disable-static
+                               --disable-xcrypt-compat-files
+                               --enable-obsolete-api=yes
+                       )
+                       ;;
+               xcrypt_nocompat-*)
+                       myconf+=(
+                               --enable-obsolete-api=no
+                               $(use_enable static-libs static)
+                       )
+               ;;
+               *) die "Unexpected MULTIBUILD_ID: ${MULTIBUILD_ID}";;
+       esac
+
+       ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+src_compile() {
+       multibuild_foreach_variant multilib-minimal_src_compile
+}
+
+multilib_src_test() {
+       emake check
+}
+
+src_test() {
+       multibuild_foreach_variant multilib-minimal_src_test
+}
+
+src_install() {
+       multibuild_foreach_variant multilib-minimal_src_install
+
+       (
+               shopt -s failglob || die "failglob failed"
+
+               # Make sure our man pages do not collide with glibc or man-pages.
+               for manpage in "${ED}"/usr/share/man/man3/crypt{,_r}.?*; do
+                       mv -n "${manpage}" "$(dirname "${manpage}")/xcrypt_$(basename "${manpage}")" \
+                               || die "mv failed"
+               done
+       ) || die "failglob error"
+
+       # remove useless stuff from installation
+       find "${D}"/usr/share/doc/${PF} -type l -delete || die
+       find "${D}" -name '*.la' -delete || die
+}
+
+multilib_src_install() {
+       emake DESTDIR="${D}" install
+
+       # don't install the libcrypt.so symlink for the "compat" version
+       case "${MULTIBUILD_ID}" in
+               xcrypt_compat-*)
+                       rm "${D}"$(get_xclibdir)/libcrypt$(get_libname) \
+                               || die "failed to remove extra compat libraries"
+               ;;
+               xcrypt_nocompat-*)
+                       if use split-usr; then
+                               (
+                                       if use static-libs; then
+                                               # .a files are installed to /$(get_libdir) by default
+                                               # move static libraries to /usr prefix or portage will abort
+                                               shopt -s nullglob || die "failglob failed"
+                                               static_libs=( "${ED}"/$(get_xclibdir)/*.a )
+
+                                               if [[ -n ${static_libs[*]} ]]; then
+                                                       dodir "/usr/$(get_xclibdir)"
+                                                       mv "${static_libs[@]}" "${D}/usr/$(get_xclibdir)" \
+                                                               || die "moving static libs failed"
+                                               fi
+                                       fi
+
+                                       if use system; then
+                                               # Move versionless .so symlinks from /$(get_libdir) to /usr/$(get_libdir)
+                                               # to allow linker to correctly find shared libraries.
+                                               shopt -s failglob || die "failglob failed"
+
+                                               for lib_file in "${ED}"$(get_xclibdir)/*$(get_libname); do
+                                                       lib_file_basename="$(basename "${lib_file}")"
+                                                       lib_file_target="$(basename "$(readlink -f "${lib_file}")")"
+                                                       dosym "../../$(get_libdir)/${lib_file_target}" "/usr/$(get_xclibdir)/${lib_file_basename}"
+                                               done
+
+                                               rm "${ED}"$(get_xclibdir)/*$(get_libname) || die "removing symlinks in incorrect location failed"
+                                       fi
+                               )
+                       fi
+               ;;
+               *) die "Unexpected MULTIBUILD_ID: ${MULTIBUILD_ID}";;
+       esac
+}