app-backup/burp: Remove ssl USE flag
authorAmadeusz Żołnowski <aidecoe@gentoo.org>
Tue, 18 Aug 2015 08:42:26 +0000 (09:42 +0100)
committerAmadeusz Żołnowski <aidecoe@gentoo.org>
Tue, 18 Aug 2015 08:42:45 +0000 (09:42 +0100)
Gentoo-Bug: 554170

Package-Manager: portage-2.2.20.1

app-backup/burp/burp-1.3.48.ebuild
app-backup/burp/burp-1.3.8.ebuild
app-backup/burp/burp-1.4.34.ebuild
app-backup/burp/burp-1.4.40.ebuild

index 5afc40f00ac78f3e9dbdd37822f281cef1c172e2..1178a6063f50a4e5ffa29248795e806b33be1864 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
 LICENSE="AGPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="acl afs ipv6 nls ssl tcpd xattr"
+IUSE="acl afs ipv6 nls tcpd xattr"
 
 DEPEND="
        dev-libs/openssl:0
@@ -58,7 +58,6 @@ src_configure() {
                --sbindir=/usr/sbin
                --sysconfdir=/etc/burp
                --enable-largefile
-               $(use_with ssl openssl)
                $(use_enable acl)
                $(use_enable afs)
                $(use_enable ipv6)
@@ -89,7 +88,7 @@ src_install() {
 }
 
 pkg_postinst() {
-       if use ssl && [ ! -e /etc/burp/CA/index.txt ]; then
+       if [[ ! -e /etc/burp/CA/index.txt ]]; then
                elog "At first run burp server will generate DH parameters and SSL"
                elog "certificates.  You should adjust configuration before."
                elog "Server configuration is located at"
index 7ac69eb8f61fce01df3a23c5115596e0181fcf23..069690a28b5d968ad624b5ccf28ff1528754487a 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI="http://burp.grke.org/downloads/${P}/${P}.tar.bz2"
 LICENSE="AGPL-3"
 SLOT="0"
 KEYWORDS="~amd64"
-IUSE="acl afs nls ssl tcpd xattr"
+IUSE="acl afs nls tcpd xattr"
 
 DEPEND="
        dev-libs/openssl:0
@@ -53,7 +53,6 @@ src_configure() {
                --sbindir=/usr/sbin
                --sysconfdir=/etc/burp
                --enable-largefile
-               $(use_with ssl openssl)
                $(use_enable acl)
                $(use_enable afs)
                $(use_enable nls)
@@ -83,7 +82,7 @@ src_install() {
 }
 
 pkg_postinst() {
-       if use ssl && [ ! -e /etc/burp/CA/index.txt ]; then
+       if [[ ! -e /etc/burp/CA/index.txt ]]; then
                elog "At first run burp server will generate DH parameters and SSL"
                elog "certificates.  You should adjust configuration before."
                elog "Server configuration is located at"
index a0eac487f509beb70f3a48664a666819606e3240..e4da6c6bb3113c37dc3c962719d62be49b4459db 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
 LICENSE="AGPL-3"
 SLOT="0"
 KEYWORDS="~amd64"
-IUSE="acl afs ipv6 nls ssl tcpd xattr"
+IUSE="acl afs ipv6 nls tcpd xattr"
 
 DEPEND="
        dev-libs/openssl:0
@@ -54,7 +54,6 @@ src_configure() {
                --sbindir=/usr/sbin
                --sysconfdir=/etc/burp
                --enable-largefile
-               $(use_with ssl openssl)
                $(use_enable acl)
                $(use_enable afs)
                $(use_enable ipv6)
@@ -85,7 +84,7 @@ src_install() {
 }
 
 pkg_postinst() {
-       if use ssl && [ ! -e /etc/burp/CA/index.txt ]; then
+       if [[ ! -e /etc/burp/CA/index.txt ]]; then
                elog "At first run burp server will generate DH parameters and SSL"
                elog "certificates.  You should adjust configuration before."
                elog "Server configuration is located at"
index a0eac487f509beb70f3a48664a666819606e3240..e4da6c6bb3113c37dc3c962719d62be49b4459db 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
 LICENSE="AGPL-3"
 SLOT="0"
 KEYWORDS="~amd64"
-IUSE="acl afs ipv6 nls ssl tcpd xattr"
+IUSE="acl afs ipv6 nls tcpd xattr"
 
 DEPEND="
        dev-libs/openssl:0
@@ -54,7 +54,6 @@ src_configure() {
                --sbindir=/usr/sbin
                --sysconfdir=/etc/burp
                --enable-largefile
-               $(use_with ssl openssl)
                $(use_enable acl)
                $(use_enable afs)
                $(use_enable ipv6)
@@ -85,7 +84,7 @@ src_install() {
 }
 
 pkg_postinst() {
-       if use ssl && [ ! -e /etc/burp/CA/index.txt ]; then
+       if [[ ! -e /etc/burp/CA/index.txt ]]; then
                elog "At first run burp server will generate DH parameters and SSL"
                elog "certificates.  You should adjust configuration before."
                elog "Server configuration is located at"