www-apps/tt-rss: Bump to current git (rolling release)
authorThomas Kahle <tomka@gentoo.org>
Fri, 30 Sep 2016 11:45:15 +0000 (13:45 +0200)
committerThomas Kahle <tomka@gentoo.org>
Fri, 30 Sep 2016 11:45:57 +0000 (13:45 +0200)
Package-Manager: portage-2.3.0

www-apps/tt-rss/Manifest
www-apps/tt-rss/tt-rss-20160930.ebuild [new file with mode: 0644]

index 8e198b5f127e634ab592295a2ab6794549d18579..5be60e8e04b718e2c97eb21bea0ece21989c1179 100644 (file)
@@ -1,2 +1,3 @@
 DIST tt-rss-20160124.tar.bz2 2059978 SHA256 90706f133db74d86aba3f8488c99ed1c886948a92c64bdb7ecaca3c3129ddf59 SHA512 d41ae8b2086e1e0ff2d69427fe9ccb8d0710e5acffe3137c408c01fc20cc3fbb30f2d4859624c14ac0ba4429deea91fa57f54b2a56a2e480f0352509610c3a25 WHIRLPOOL 09b4c5515c8a19c3cfcd330761fcb9534185df8cb3ef7832c28f0200d15846b031817e72204cf28881101ad2ecc867ad4369f22afef9947b8b82521feb07083b
 DIST tt-rss-20160527.tar.bz2 2064633 SHA256 fd0beae76848eff39d9413820f9c575baf41283d2635bdb0e37cfc286bcc3a2c SHA512 8d482303868a08f4d65ef252f71f66ec3219d4f67e968a026a0302d29930cd5af45cedea81171db2ff0927497079d3bedd8fd70e4e9904f5d9987a92a6dfcb89 WHIRLPOOL 247ef0bc9d2049936a16340f2a5f26be8eb2d4d072d290d254ebc9666c81456f7d59271813be1ed3963537e6f86cf2b28f4447af8bcc559a64d8f2ce0d7f6952
+DIST tt-rss-20160930.tar.bz2 2072888 SHA256 5a7ff9d2e71cca0afb534558f4069264433eeaccf5cb02f425f06bbb7870d8db SHA512 d420e7efdf7d17e153ef0aa487a330379afe20fe9e9a6209de40b797d36e425cbcbdf2280eaf5ada8b9bef1ae37146253556ff602bbff22a9a7c311ff525d9e2 WHIRLPOOL 0da0f79cedda6be728f03a0e626cad610576cfad0165ad0e2ddbc54ee0ba778a935be131265874ee0e63cee8fcf620fd275d0588534f9cd5bc4505afe032d663
diff --git a/www-apps/tt-rss/tt-rss-20160930.ebuild b/www-apps/tt-rss/tt-rss-20160930.ebuild
new file mode 100644 (file)
index 0000000..7cfd32c
--- /dev/null
@@ -0,0 +1,89 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit user eutils webapp vcs-snapshot
+
+DESCRIPTION="Tiny Tiny RSS - A web-based news feed (RSS/Atom) aggregator using AJAX"
+HOMEPAGE="http://tt-rss.org/"
+SRC_URI="https://dev.gentoo.org/~tomka/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="daemon +mysql postgres"
+
+DEPEND="
+       daemon? ( dev-lang/php:*[mysql?,postgres?,pcntl,curl] )
+       !daemon? ( dev-lang/php:*[mysql?,postgres?,curl] )
+       virtual/httpd-php:*
+"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="|| ( mysql postgres )"
+
+need_httpd_cgi  # From webapp.eclass
+
+pkg_setup() {
+       webapp_pkg_setup
+
+       if use daemon; then
+                       enewgroup ttrssd
+                       enewuser ttrssd -1 /bin/sh /dev/null ttrssd
+       fi
+}
+
+src_prepare() {
+       # Customize config.php-dist so that the right 'DB_TYPE' is already set (according to the USE flag)
+       einfo "Customizing config.php-dist..."
+
+       if use mysql && ! use postgres; then
+                       sed -i \
+                               -e "/define('DB_TYPE',/{s:pgsql:mysql:}" \
+                               config.php-dist || die
+       fi
+
+       sed -i \
+               -e "/define('DB_TYPE',/{s:// \(or mysql\):// pgsql \1:}" \
+               config.php-dist || die
+
+       # per 462578
+       epatch_user
+}
+
+src_install() {
+       webapp_src_preinst
+
+       insinto "/${MY_HTDOCSDIR}"
+       doins -r *
+       keepdir "/${MY_HTDOCSDIR}"/feed-icons
+
+       for DIR in cache lock feed-icons; do
+                       webapp_serverowned -R "${MY_HTDOCSDIR}/${DIR}"
+       done
+
+       # In the old days we put a config.php directly and tried to
+       # protect it with the following which did not work reliably.
+       # These days we only install the config.php-dist file.
+       # webapp_configfile "${MY_HTDOCSDIR}"/config.php
+
+       if use daemon; then
+                       webapp_postinst_txt en "${FILESDIR}"/postinstall-en-with-daemon.txt
+                       newinitd "${FILESDIR}"/ttrssd.initd-r2 ttrssd
+                       newconfd "${FILESDIR}"/ttrssd.confd-r1 ttrssd
+                       insinto /etc/logrotate.d/
+                       newins "${FILESDIR}"/ttrssd.logrotated ttrssd
+
+                       elog "After upgrading, please restart ttrssd"
+       else
+                       webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+       fi
+
+       webapp_src_install
+}
+
+pkg_postinst() {
+       elog "You need to merge config.php and config.php-dist manually now."
+       webapp_pkg_postinst
+}