dev-perl/Path-Tiny: Bump to version 0.104.0
authorKent Fredric <kentnl@gentoo.org>
Wed, 5 Apr 2017 19:54:02 +0000 (07:54 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 5 Apr 2017 19:54:17 +0000 (07:54 +1200)
Upstream:
- Fix bugs in relative symlink resolution
- Detects circular loops in symlinks and errors
- spew_utf8 accepts arrayref as input
- Prefer PerlIO::utf8_strict over encoding(UTF-8)
- 'touch' can now set current time on writeable unowned files
- Symlink support detection always looks at $Config{d_symlink}
- Add 'realpath' option to tempfile/tempdir
- Fix '.' in @INC issues
- 'absolute' always returns absolute paths even with relative
  base paths
- Add 'cached_temp'

Package-Manager: Portage-2.3.4, Repoman-2.3.2

dev-perl/Path-Tiny/Manifest
dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild [new file with mode: 0644]
dev-perl/Path-Tiny/metadata.xml

index b59945c1a5947377e7b9d791f185574685a3bac1..0dd36753670f8ce90dad21d44ee7dd22aeb8332d 100644 (file)
@@ -1,2 +1,3 @@
 DIST Path-Tiny-0.061.tar.gz 71937 SHA256 e8290aac8c0623eea1b20b4a9d9a1be08db7f5a92ea51a514677964f3fa01cca SHA512 36efc16e8dc2046f4a0c458be464be54769ec721d09201970d7f4d9c87acb03b91f16b673e63fc8212574f47bad31f59006cc50eb242f071d271294408c397a0 WHIRLPOOL c0bf53e78b82a8f9351698de875dad339c821e3dccf5f7ee8add3ed7d3d11baacf43e5442d8481d1cdefce94da89e2d80eff28dbbaa1c6a5d6519e51a647d375
 DIST Path-Tiny-0.084.tar.gz 89052 SHA256 633f463e380404d4aaa8ebdd1977b5e387256aa2770eb142b169737978749bea SHA512 c8a5853f04afdb5d8db1e8f533d4706cf1030caefbb0f1b05f0fab7b71de34a0463269ba1733f549d1c1c7a370ce88f428d108387b10c6cb56c668280e2449c6 WHIRLPOOL ecf8a851796e958520e1433a4b4e7861b6c94a8ef215a41df7392d6414d9bd9df54aa7ca87f47a13f8c234ebc71d1b8aefdc5245c9c519e8cc42ecf7aa3abf43
+DIST Path-Tiny-0.104.tar.gz 93011 SHA256 c69f1dcfeb4aa004086deb9bc14c7d79f45798b947f1efbd634a3442e267aaef SHA512 6574e48645ebb4f61d45c1365e8b63cfaac6423394ba08363cfd62d3d98d163bd333d997bf5f7fd0e37ff94fcb3a3e19871eb7499b295399f048fd6a4bd3c78c WHIRLPOOL 6ca6eb2a0000e0569bf022e75044c3f1737b5d53dd2f3eb5f1038f36607612c3f6c5b459313ed6706629880509c956c0ce07bf1557de92daac7bffa3222aae0d
diff --git a/dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild b/dev-perl/Path-Tiny/Path-Tiny-0.104.0.ebuild
new file mode 100644 (file)
index 0000000..ba20c35
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=0.104
+inherit perl-module
+
+DESCRIPTION="File path utility"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+       !minimal? (
+               >=dev-perl/Unicode-UTF8-0.580.0
+       )
+       virtual/perl-Carp
+       >=virtual/perl-Digest-1.30.0
+       >=virtual/perl-Digest-SHA-5.450.0
+       >=virtual/perl-Exporter-5.570.0
+       >=virtual/perl-File-Path-2.70.0
+       >=virtual/perl-File-Spec-0.860.0
+       >=virtual/perl-File-Temp-0.190.0
+       virtual/perl-if
+"
+DEPEND="${RDEPEND}
+       >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+       test? (
+               !minimal? (
+                       >=virtual/perl-JSON-PP-2.273.0
+                       dev-perl/Test-FailWarnings
+                       dev-perl/Test-MockRandom
+               )
+               >=virtual/perl-Test-Simple-0.960.0
+       )
+"
index a2bf08803f0efc127f5942e6e40736b77516f253..0bc40aa713cb7e37d30962065663882602475983 100644 (file)
@@ -1,12 +1,13 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<maintainer type="project">
-<email>perl@gentoo.org</email>
-<name>Gentoo Perl Project</name>
-</maintainer>
-<upstream>
-<remote-id type="cpan">Path-Tiny</remote-id>
-<remote-id type="cpan-module">Path::Tiny</remote-id>
-</upstream>
+  <maintainer type="project">
+    <email>perl@gentoo.org</email>
+    <name>Gentoo Perl Project</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="cpan">Path-Tiny</remote-id>
+    <remote-id type="cpan-module">Path::Tiny</remote-id>
+    <remote-id type="cpan-module">Path::Tiny::Error</remote-id>
+  </upstream>
 </pkgmetadata>