dev-libs/aws-c-common: Core c99 package for AWS SDK for C
authorSven Eden <yamakuzure@gmx.net>
Thu, 15 Aug 2019 16:15:44 +0000 (18:15 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 20 Sep 2019 15:23:28 +0000 (18:23 +0300)
Includes cross-platform primitives, configuration, data structures, and
error handling.
Dependency for dev-libs/aws-sdk-cpp-1.7.178

Signed-off-by: Sven Eden <yamakuzure@gmx.net>
Bug: https://bugs.gentoo.org/666494
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/aws-c-common/Manifest [new file with mode: 0644]
dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild [new file with mode: 0644]
dev-libs/aws-c-common/metadata.xml [new file with mode: 0644]

diff --git a/dev-libs/aws-c-common/Manifest b/dev-libs/aws-c-common/Manifest
new file mode 100644 (file)
index 0000000..88ca38b
--- /dev/null
@@ -0,0 +1 @@
+DIST aws-c-common-0.4.11.tar.gz 306933 BLAKE2B 5a2370a3696e4d90b67bc03fbf88f152e1a2d6e4d4a9ff2a9423a2cf18c14a1e3b6d978250c3359f4ebb2cf5e524e416b11604dc09dc45f5c8a5a6f982b344a7 SHA512 1e00f6aa025578978551fc8ca1bc09b448f79ac28bdc969af4312569ffca035d656dc68825da15ad8f4f890bbdb03327c624147dded1ce402e9dab1726290890
diff --git a/dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild b/dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild
new file mode 100644 (file)
index 0000000..e67469e
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Core c99 package for AWS SDK for C"
+HOMEPAGE="https://github.com/awslabs/aws-c-common"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+src_configure() {
+       local mycmakeargs=(
+               -DBUILD_TESTING=$(usex test)
+       )
+       cmake-utils_src_configure
+}
diff --git a/dev-libs/aws-c-common/metadata.xml b/dev-libs/aws-c-common/metadata.xml
new file mode 100644 (file)
index 0000000..6822263
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>yamakuzure@gmx.net</email>
+               <name>Sven Eden</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <longdescription>
+               Core c99 package for AWS SDK for C. Includes cross-platform primitives,
+               configuration, data structures, and error handling.
+       </longdescription>
+</pkgmetadata>