dev-python/munkres: version bump to v1.0.12.
authorJoshua Downer <joshua.downer@gmail.com>
Thu, 12 Oct 2017 13:41:40 +0000 (13:41 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Wed, 18 Oct 2017 17:29:25 +0000 (19:29 +0200)
Closes: https://github.com/gentoo/gentoo/pull/5928

dev-python/munkres/Manifest
dev-python/munkres/metadata.xml
dev-python/munkres/munkres-1.0.12.ebuild [new file with mode: 0644]

index 9ebe8f0696bf0b94d365b34dfd26380800a148da..3d99e8ea31a390da38583e5c9d57a215afb9a1ce 100644 (file)
@@ -1,2 +1,3 @@
+DIST munkres-1.0.12.tar.gz 12126 SHA256 70b3b32b4fed3b354e5c42e4d1273880a33a13ab8c108a4247140eb661767a0b SHA512 9049fd350b739c9095b6e1da8fe0041210d4723ab8c0c6a7fc9943392bebf9eb224c6f420c8158a47607277e13fba2f3c7803ee222d58e8e3720d5647f44e596 WHIRLPOOL 809df436f7e583b3a6ae31b161d0f1d33f749dd4c5a4bb018b04fb440964e5fff1625689fb29c2c5c4327c24b631fe5b0c5a5df5c552e8b2705d13e1d529d3f7
 DIST munkres-1.0.5.4.tar.gz 43050 SHA256 105adad30659dbdf82815d3e12a74d4c01a3e0741d5ccbce194ee2ad4e5338d2 SHA512 a2b1577b75f3099cae57750543c985ab60097d5fa70481d3c6d8394dd55d0d8f99aacf5db625be7fa12772e976cf34d4b51c7841c3a24ee9df8214a68aa66aed WHIRLPOOL de64e126d37a0d267c0048ba368ab58f34aa9ae0d41cc3a97019370d3c12b231bee206c0c0f87d28f22e4b4ac1c29cd054350522372574437b6a09204d1a6561
 DIST munkres-1.0.8.tar.gz 9277 SHA256 185f1a9c4d2c31f2f19afa48bc2ec726c11e945eded4784d272da2fd49bf7a55 SHA512 e0afda8b91e51d177b9e2dc66ccacce849649d1a7d0e756884ac030acf4080076aa428182c5e9366613ee16db338ba7dcd3c38977de0888781b1885f08cb8236 WHIRLPOOL 15647beb863b6a2eb52ef594457564a524f8a6c4a4287f522679a3e1abc334279a9d3b47d0e7611ebb6c37c0549220c323bb6c4811f2097105f47d43a538653b
index 7c1499e711dd4fc42f5bf5df3ccf06c4a0b491a1..0da8fb3055852b5e10c6fac16126069e193253f2 100644 (file)
@@ -10,7 +10,7 @@
     <name>Proxy Maintainers</name>
   </maintainer>
   <longdescription lang="en">The Munkres module provides an implementation of the Munkres algorithm (also called the Hungarian algorithm or the Kuhn-Munkres algorithm), useful for solving the Assignment Problem.
-       </longdescription>
+  </longdescription>
   <upstream>
     <remote-id type="pypi">munkres</remote-id>
   </upstream>
diff --git a/dev-python/munkres/munkres-1.0.12.ebuild b/dev-python/munkres/munkres-1.0.12.ebuild
new file mode 100644 (file)
index 0000000..aa28278
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module implementing munkres algorithm for the Assignment Problem"
+HOMEPAGE="https://pypi.python.org/pypi/munkres/"
+SRC_URI="https://github.com/bmc/munkres/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+python_test() {
+       "${PYTHON}" ${PN}.py || die
+}