app-emulation/virt-manager: fix configuration craziness
authorMatthias Maier <tamiko@gentoo.org>
Sun, 19 Apr 2020 00:31:41 +0000 (19:31 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 19 Apr 2020 00:31:41 +0000 (19:31 -0500)
Closes: https://bugs.gentoo.org/717886
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-emulation/virt-manager/virt-manager-2.2.1-r2.ebuild

index ee09a0d573f20d454042a7f8f7daf3e35af5706a..229e27a53dfd275da488099e9f9f3500168faf9a 100644 (file)
@@ -6,6 +6,7 @@ EAPI=6
 PYTHON_COMPAT=( python3_{6,7} )
 DISTUTILS_SINGLE_IMPL=1
 
+DISTUTILS_USE_SETUPTOOLS=no
 inherit gnome2 distutils-r1
 
 DESCRIPTION="A graphical tool for administering virtual machines"
@@ -59,9 +60,7 @@ src_prepare() {
        distutils-r1_src_prepare
 }
 
-distutils-r1_python_compile() {
-       local defgraphics=
-
+python_configure() {
        esetup.py configure \
                --default-graphics=spice
 }