games-emulation/desmume: Remove unneeded gtkglext dependency
authorHanno <hanno@gentoo.org>
Sat, 2 Nov 2019 14:59:59 +0000 (15:59 +0100)
committerHanno <hanno@gentoo.org>
Sat, 2 Nov 2019 14:59:59 +0000 (15:59 +0100)
Port to EAPI 7.

Closes: https://bugs.gentoo.org/698962
Closes: https://github.com/gentoo/gentoo/pull/13506
Signed-off-by: Hanno Boeck <hanno@gentoo.org>
Package-Manager: Portage-2.3.78, Repoman-2.3.17

games-emulation/desmume/desmume-0.9.11-r2.ebuild [new file with mode: 0644]

diff --git a/games-emulation/desmume/desmume-0.9.11-r2.ebuild b/games-emulation/desmume/desmume-0.9.11-r2.ebuild
new file mode 100644 (file)
index 0000000..964f794
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="Nintendo DS emulator"
+HOMEPAGE="http://desmume.org/"
+SRC_URI="mirror://sourceforge/desmume/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+       dev-libs/zziplib
+       gnome-base/libglade
+       media-libs/libsdl[joystick,opengl,video]
+       sys-libs/zlib
+       virtual/opengl
+       x11-libs/agg
+       >=x11-libs/gtk+-2.8.0:2"
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README README.LIN )
+
+# fix QA compiler warning, see
+# https://sourceforge.net/p/desmume/patches/172/
+PATCHES=(
+       "${FILESDIR}/${P}-fix-pointer-conversion-warning.diff"
+       "${FILESDIR}/${P}-gcc6.patch"
+       "${FILESDIR}/${P}-gcc7.patch"
+)