dev-python/logbook: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 20:56:14 +0000 (21:56 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 20:56:14 +0000 (21:56 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/logbook/Manifest
dev-python/logbook/logbook-1.1.0.ebuild [deleted file]

index cfa0e80196d7bbba7e84d94e213ad37eff38db75..d86e773ed3a7f0e244c64c18c1f700775f08f4df 100644 (file)
@@ -1,2 +1 @@
-DIST logbook-1.1.0.tar.gz 367541 BLAKE2B 26e27e94f1238c9188fc66b6eb1f5622d96e1c0db97817dba30c8c70107544ea80ab1f11b71592db6a8e2a9c5d32dd659782a532cb7d263c2f042b41ef88d2ad SHA512 55ec7a026a08baed405e29d7cdcc9d3cc423c9faf13788c2447ac7ccff688de9bd9e332ad78077b1eef8bc8ad9aea572f9c124888f46ecabc2abf22d8ac9086b
 DIST logbook-1.4.0.tar.gz 369335 BLAKE2B 02398be49d2a12aadbcde90561afe6ac08060877922fa04b27f08587115aef8faf47bfc352fc005b8a986ab619289c8544fe53a84e0e863a09c992685f78739c SHA512 3ea969e9e2075e34a915566be906266b408671657e4cecbe47663c28f2212c0522b0f0eb2832fbc4fb906f70c8e53d3cdbe65923dafe53a77545b8126ab539f2
diff --git a/dev-python/logbook/logbook-1.1.0.ebuild b/dev-python/logbook/logbook-1.1.0.ebuild
deleted file mode 100644 (file)
index f136b6b..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A logging replacement for Python"
-HOMEPAGE="https://logbook.readthedocs.io/en/stable/
-       https://github.com/getlogbook/logbook
-       https://pypi.org/project/Logbook/"
-SRC_URI="https://github.com/getlogbook/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-       doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
-RDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )
-
-python_prepare_all() {
-       # Delete test file requiring local connection to redis server
-       rm tests/test_queues.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       py.test tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}