dev-ml/ocaml-ssl: bump to 0.5.4
authorAlexis Ballier <aballier@gentoo.org>
Wed, 4 Oct 2017 07:48:36 +0000 (09:48 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 4 Oct 2017 08:01:43 +0000 (10:01 +0200)
Package-Manager: Portage-2.3.11, Repoman-2.3.3

dev-ml/ocaml-ssl/Manifest
dev-ml/ocaml-ssl/ocaml-ssl-0.5.4.ebuild [new file with mode: 0644]

index a89c84b8e14f8909e932ef5d810e39cc924c7746..a1be7be9b23f0d29617acb538542c770476f884c 100644 (file)
@@ -1 +1,2 @@
 DIST ocaml-ssl-0.5.3.tar.gz 125431 SHA256 9ef78eeb83ab7f0bb2244625d44543fbc8624c952731b3eb213a9c2a96213aa0 SHA512 c0dc38ab21c8adc104a42ec89b8a58de976205887a23a407f1ffee1181d526ddb8aa91877508f8a974c6df8583d6d8611558a995680e313fc78ad0cac184cf52 WHIRLPOOL 098454a79c2fcbe1438feae475a4ed01a645db137d4f130cd6c8f0aa3ac237719d984562deb0319091d01e84b98b5a67096b2964edf42e38acecedaa5f57aa53
+DIST ocaml-ssl-0.5.4.tar.gz 125833 SHA256 10db195bf06178413bec17898f89eb858e1fb97225f03137790d3fd840bc4cce SHA512 4a221bd8f5c11871040f6f117d3152ec2fca28f0311dfcc2ac39d2ed55c66203e12ad3242368273d8f17f1ca87c1b5d929ab7fec8ec7a03a564c7c25ade3d289 WHIRLPOOL db76056ae19cc144e677f45c2d9ad83fbb958cc7dcbdc4078008434c68df2fe6fe60ddbdf2fd4442284d3593cdd2e1f5f6607ec9567144a989010bf1e4dd58e1
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.5.4.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.4.ebuild
new file mode 100644 (file)
index 0000000..93d736e
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+SRC_URI="https://github.com/savonet/ocaml-ssl/releases/download/${PV}/${P}.tar.gz"
+HOMEPAGE="https://github.com/savonet/ocaml-ssl"
+
+DEPEND="dev-libs/openssl:0=
+       >=dev-lang/ocaml-3.10:="
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+       emake -j1
+}
+
+src_install() {
+       findlib_src_preinst
+       emake install
+
+       if use doc; then
+               dohtml -r doc/html/*
+       fi
+       dodoc CHANGES README.md
+}