dev-haskell/configurator: new package to read config files in Haskell.
authorMichael Orlitzky <mjo@gentoo.org>
Thu, 14 Jul 2016 16:30:17 +0000 (12:30 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Fri, 15 Jul 2016 15:04:57 +0000 (11:04 -0400)
Package-Manager: portage-2.2.28

dev-haskell/configurator/Manifest [new file with mode: 0644]
dev-haskell/configurator/configurator-0.3.0.0-r1.ebuild [new file with mode: 0644]
dev-haskell/configurator/metadata.xml [new file with mode: 0644]

diff --git a/dev-haskell/configurator/Manifest b/dev-haskell/configurator/Manifest
new file mode 100644 (file)
index 0000000..31cea2f
--- /dev/null
@@ -0,0 +1 @@
+DIST configurator-0.3.0.0.tar.gz 15232 SHA256 6eb9996b672e9f7112ca23482c42fa533553312c3c13f38a8a06476e67c031b4 SHA512 0c4c95b3182874c87c4b6b8e74bf8e39ec7528b49f06e9a02baed5fa4aa90a22a9504f59e881c17616ef95a1aa5450b431df8cc9317ef837d8e821f330e303c9 WHIRLPOOL c2f814197a26254f9c8881f20d913d88a24fc7030050f2c264550b379fd45f188eff405bbcb863739773a56e5cfb1a338ac01aa39d9cb5a16ccf54d22045dbc3
diff --git a/dev-haskell/configurator/configurator-0.3.0.0-r1.ebuild b/dev-haskell/configurator/configurator-0.3.0.0-r1.ebuild
new file mode 100644 (file)
index 0000000..c58f248
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.2.9999
+#hackport: flags: -developer
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Configuration management"
+HOMEPAGE="https://github.com/bos/configurator"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.0.2:=[profile?]
+       dev-haskell/hashable:=[profile?]
+       >=dev-haskell/text-0.11.1.0:=[profile?]
+       dev-haskell/unix-compat:=[profile?]
+       dev-haskell/unordered-containers:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.8
+       test? ( dev-haskell/hunit
+               dev-haskell/test-framework
+               dev-haskell/test-framework-hunit )
+"
+
+src_configure() {
+       haskell-cabal_src_configure \
+               --flag=-developer
+}
diff --git a/dev-haskell/configurator/metadata.xml b/dev-haskell/configurator/metadata.xml
new file mode 100644 (file)
index 0000000..e605a4e
--- /dev/null
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               A configuration management library for programs and daemons.
+               
+               Features include:
+               
+               * Automatic, dynamic reloading in response to modifications to
+               configuration files.
+               
+               * A simple, but flexible, configuration language, supporting several
+               of the most commonly needed types of data, along with
+               interpolation of strings from the configuration or the system
+               environment (e.g. @$(HOME)@).
+               
+               * Subscription-based notification of changes to configuration
+               properties.
+               
+               * An @import@ directive allows the configuration of a complex
+               application to be split across several smaller files, or common
+               configuration data to be shared across several applications.
+               
+               For details of the configuration file format, see
+               &lt;http://hackage.haskell.org/packages/archive/configurator/latest/doc/html/Data-Configurator.html&gt;.
+       </longdescription>
+</pkgmetadata>