dev-python/slackclient: bump & add self as maintainer
authorRobin H. Johnson <robbat2@gentoo.org>
Mon, 6 Apr 2020 18:47:50 +0000 (11:47 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Mon, 6 Apr 2020 18:48:49 +0000 (11:48 -0700)
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
dev-python/slackclient/Manifest [new file with mode: 0644]
dev-python/slackclient/metadata.xml [new file with mode: 0644]
dev-python/slackclient/slackclient-2.5.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/slackclient/Manifest b/dev-python/slackclient/Manifest
new file mode 100644 (file)
index 0000000..f70f221
--- /dev/null
@@ -0,0 +1 @@
+DIST slackclient-2.5.0.tar.gz 49814 BLAKE2B 19f9e66af086d431494de0ef7f3569657eb769022223d0e9b0f74c0600858e20de397fd385dc1c41d416eb3a98a7437d2b0c1b5e156be6d98941b26749103c5b SHA512 3a7a1e741e81e673cb09f8b1d9a18ca3d0e7a0e41a7ac6062725b87752f3877548faa0f9150eb1b1775479dfe9035d03fd4d991ac108b0f634cc179f4b70e2db
diff --git a/dev-python/slackclient/metadata.xml b/dev-python/slackclient/metadata.xml
new file mode 100644 (file)
index 0000000..aee7e2f
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>robbat2@gentoo.org</email>
+               <name>Robin H. Johnson</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+               <name>Python</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">slackapi/python-slackclient</remote-id>
+               <remote-id type="pypi">slackclient</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/slackclient/slackclient-2.5.0.ebuild b/dev-python/slackclient/slackclient-2.5.0.ebuild
new file mode 100644 (file)
index 0000000..c5f5e7e
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Client for Slack supporting the Slack Web and Real Time Messaging API"
+HOMEPAGE="https://github.com/slackapi/python-slackclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # upstream does not include tests in the package tarball!
+
+RDEPEND="
+       >dev-python/aiohttp-3.5.2[${PYTHON_USEDEP}]
+       >dev-python/aiodns-1.0.0[${PYTHON_USEDEP}]
+       "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${RDEPEND}"