dev-python/pyClamd: Add python 3.7 support.
authorHanno <hanno@gentoo.org>
Mon, 16 Sep 2019 06:56:33 +0000 (08:56 +0200)
committerHanno <hanno@gentoo.org>
Mon, 16 Sep 2019 06:56:56 +0000 (08:56 +0200)
Add myself as maintainer.

Bug: https://bugs.gentoo.org/694280
Signed-off-by: Hanno Boeck <hanno@gentoo.org>
Package-Manager: Portage-2.3.76, Repoman-2.3.17

dev-python/pyClamd/metadata.xml
dev-python/pyClamd/pyClamd-0.4.0-r1.ebuild [new file with mode: 0644]

index bfc26d648e7ccc598e85c8c55445eef672a71ac5..9e0c0672b1cafd28739c4615540943c37e076619 100644 (file)
@@ -1,7 +1,9 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-  <!-- maintainer-needed -->
+  <maintainer type="person">
+    <email>hanno@gentoo.org</email>
+  </maintainer>
   <upstream>
     <remote-id type="pypi">pyClamd</remote-id>
   </upstream>
diff --git a/dev-python/pyClamd/pyClamd-0.4.0-r1.ebuild b/dev-python/pyClamd/pyClamd-0.4.0-r1.ebuild
new file mode 100644 (file)
index 0000000..dfcc0c7
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="https://xael.org/pages/pyclamd-en.html"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+       sed -e 's:/etc/clamav/clamd.conf:/etc/clamd.conf:' \
+               -i pyclamd/pyclamd.py || die
+}