Revert r6967 since shutil.move() is broken internally.
authorZac Medico <zmedico@gentoo.org>
Sat, 23 Jun 2007 13:09:30 +0000 (13:09 -0000)
committerZac Medico <zmedico@gentoo.org>
Sat, 23 Jun 2007 13:09:30 +0000 (13:09 -0000)
svn path=/main/trunk/; revision=6970

pym/emerge/__init__.py
pym/portage/dbapi/bintree.py
pym/portage/dbapi/vartree.py
pym/portage/dispatch_conf.py

index ac74f12d2148b37797dc15309bddf82e7da9852b..17ff8d58dd324350a40627f310eb1950ed169ace 100644 (file)
@@ -3754,17 +3754,14 @@ def chk_updated_info_files(root, infodirs, prev_mtimes, retval):
 
                        icount=0
                        badcount=0
-                       import shutil
                        for inforoot in regen_infodirs:
                                if inforoot=='':
                                        continue
                                for filename in ("dir", "dir.gz", "dir.bz2"):
                                        file_path = os.path.join(inforoot, filename)
-                                       if not os.path.exists(file_path):
-                                               continue
                                        try:
-                                               shutil.move(file_path, file_path + ".old")
-                                       except EnvironmentError, e:
+                                               os.rename(file_path, file_path + ".old")
+                                       except OSError, e:
                                                if e.errno != errno.ENOENT:
                                                        raise
                                                del e
index 9e3ce0dd9bf729f457a18bb38c177678f6d2d8ad..3242cc158f2c25bf28f2ae000e10d4ba35ecdd63 100644 (file)
@@ -14,7 +14,7 @@ from portage import listdir, dep_expand
 
 import portage.xpak, portage.getbinpkg
 
-import os, errno, shutil, stat
+import os, errno, stat
 
 class bindbapi(fakedbapi):
        def __init__(self, mybintree=None, settings=None):
@@ -206,7 +206,7 @@ class binarytree(object):
                                        if e.errno != errno.EEXIST:
                                                raise
                                        del e
-                               shutil.move(tbz2path, new_path)
+                               os.rename(tbz2path, new_path)
                                self._remove_symlink(mycpv)
                                if new_path.split(os.path.sep)[-2] == "All":
                                        self._create_symlink(mynewcpv)
@@ -299,7 +299,7 @@ class binarytree(object):
                                if e.errno != errno.EEXIST:
                                        raise
                                del e
-                       shutil.move(src_path, os.path.join(self.pkgdir, "All", myfile))
+                       os.rename(src_path, os.path.join(self.pkgdir, "All", myfile))
                        self._create_symlink(cpv)
                self._pkg_paths[cpv] = os.path.join("All", myfile)
 
@@ -317,7 +317,7 @@ class binarytree(object):
                        if e.errno != errno.EEXIST:
                                raise
                        del e
-               shutil.move(os.path.join(self.pkgdir, "All", myfile), dest_path)
+               os.rename(os.path.join(self.pkgdir, "All", myfile), dest_path)
                self._pkg_paths[cpv] = mypath
 
        def populate(self, getbinpkgs=0, getbinpkgsonly=0):
@@ -681,7 +681,7 @@ class binarytree(object):
                        pkgindex_lock = lockfile(self._pkgindex_file,
                                wantnewlockfile=1)
                        if filename is not None:
-                               shutil.move(filename, self.getname(cpv))
+                               os.rename(filename, self.getname(cpv))
                        if self._all_directory and \
                                self.getname(cpv).split(os.path.sep)[-2] == "All":
                                self._create_symlink(cpv)
index b15cede57366afd37318a4b7e3bf877c2004b075..5cf81c425277cd08534bbb16ad004acd07c1e194 100644 (file)
@@ -24,7 +24,7 @@ from portage import listdir, dep_expand, config, flatten, key_expand, \
        doebuild_environment, doebuild, env_update, \
        abssymlink, movefile, bsd_chflags
 
-import commands, copy, errno, os, shutil, stat, sys
+import os, sys, stat, errno, commands, copy, time
 from itertools import izip
 
 try:
@@ -301,14 +301,14 @@ class vardbapi(dbapi):
                        if os.path.exists(newpath):
                                #dest already exists; keep this puppy where it is.
                                continue
-                       shutil.move(origpath, newpath)
+                       os.rename(origpath, newpath)
 
                        # We need to rename the ebuild now.
                        old_pf = catsplit(mycpv)[1]
                        new_pf = catsplit(mynewcpv)[1]
                        if new_pf != old_pf:
                                try:
-                                       shutil.move(os.path.join(newpath, old_pf + ".ebuild"),
+                                       os.rename(os.path.join(newpath, old_pf + ".ebuild"),
                                                os.path.join(newpath, new_pf + ".ebuild"))
                                except EnvironmentError, e:
                                        if e.errno != errno.ENOENT:
@@ -1031,7 +1031,7 @@ class dblink(object):
                                if x[:-7] != self.pkg:
                                        # Clean up after vardbapi.move_ent() breakage in
                                        # portage versions before 2.1.2
-                                       shutil.move(os.path.join(self.dbdir, x), myebuildpath)
+                                       os.rename(os.path.join(self.dbdir, x), myebuildpath)
                                        write_atomic(os.path.join(self.dbdir, "PF"), self.pkg+"\n")
                                break
 
index 6df0146d5d233df9ddfe2f6713dba6c74dde1d94..690772bf85a6c201b439811de7e0c3e8eaec0199 100644 (file)
@@ -7,7 +7,7 @@
 # Library by Wayne Davison <gentoo@blorf.net>, derived from code
 # written by Jeremy Wohl (http://igmus.org)
 
-from stat import ST_GID, ST_MODE, ST_UID
+from stat import *
 import os, sys, commands, shutil
 
 import portage
@@ -72,7 +72,7 @@ def rcs_archive(archive, curconf, newconf, mrgconf):
         os.system(RCS_GET + ' -r' + RCS_BRANCH + ' ' + archive)
         has_branch = os.path.exists(archive)
         if has_branch:
-            shutil.move(archive, archive + '.dist')
+            os.rename(archive, archive + '.dist')
 
         try:
             shutil.copy2(newconf, archive)
@@ -87,7 +87,7 @@ def rcs_archive(archive, curconf, newconf, mrgconf):
                 mystat = os.lstat(newconf)
                 os.chmod(mrgconf, mystat[ST_MODE])
                 os.chown(mrgconf, mystat[ST_UID], mystat[ST_GID])
-        shutil.move(archive, archive + '.dist.new')
+        os.rename(archive, archive + '.dist.new')
     return ret
 
 
@@ -112,10 +112,10 @@ def file_archive(archive, curconf, newconf, mrgconf):
             suf += 1
 
         while suf > 1:
-            shutil.move(archive + '.' + str(suf-1), archive + '.' + str(suf))
+            os.rename(archive + '.' + str(suf-1), archive + '.' + str(suf))
             suf -= 1
 
-        shutil.move(archive, archive + '.1')
+        os.rename(archive, archive + '.1')
 
     try:
         shutil.copy2(curconf, archive)
@@ -145,7 +145,7 @@ def file_archive(archive, curconf, newconf, mrgconf):
 def rcs_archive_post_process(archive):
     """Check in the archive file with the .dist.new suffix on the branch
     and remove the one with the .dist suffix."""
-    shutil.move(archive + '.dist.new', archive)
+    os.rename(archive + '.dist.new', archive)
     if os.path.exists(archive + '.dist'):
         # Commit the last-distributed version onto the branch.
         os.system(RCS_LOCK + RCS_BRANCH + ' ' + archive)
@@ -158,4 +158,4 @@ def rcs_archive_post_process(archive):
 
 def file_archive_post_process(archive):
     """Rename the archive file with the .dist.new suffix to a .dist suffix"""
-    shutil.move(archive + '.dist.new', archive + '.dist')
+    os.rename(archive + '.dist.new', archive + '.dist')