dev-python/pycairo: Fix the fix
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 7 Dec 2019 14:34:35 +0000 (15:34 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 7 Dec 2019 14:37:34 +0000 (15:37 +0100)
Closes: https://bugs.gentoo.org/702210
Package-Manager: Portage-2.3.81, Repoman-2.3.19
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/pycairo/pycairo-1.18.2.ebuild

index d1e334554fd14b0be26361c178f37c6d9a6dc619..9f1cd5f0198d2ae6b14fc4f52c19911c6e79cc34 100644 (file)
@@ -32,7 +32,8 @@ DEPEND="${RDEPEND}"
 RESTRICT="!test? ( test )"
 
 python_check_deps() {
-       use doc && has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+       use doc || return 0
+       has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
 }
 
 python_compile_all() {