www-client/seamonkey: Fixed build with gcc9
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 17 Jun 2019 14:31:18 +0000 (16:31 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 17 Jun 2019 14:31:18 +0000 (16:31 +0200)
Thanks-to: Helmut Jarausch <jarausch@igpm.rwth-aachen.de>
Closes: https://bugs.gentoo.org/685092
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
www-client/seamonkey/files/seamonkey-gcc9.patch [new file with mode: 0644]
www-client/seamonkey/seamonkey-2.49.9.1_p0.ebuild

diff --git a/www-client/seamonkey/files/seamonkey-gcc9.patch b/www-client/seamonkey/files/seamonkey-gcc9.patch
new file mode 100644 (file)
index 0000000..87d14e6
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/mozilla/js/xpconnect/src/XPCWrappedNative.cpp.ORIG       2018-07-09 21:54:43.000000000 +0200
++++ b/mozilla/js/xpconnect/src/XPCWrappedNative.cpp    2019-05-04 17:49:23.893560494 +0200
+@@ -2218,15 +2218,16 @@
+                 const char* fmt = (i == 0) ?
+                                     "(%s" : (i == count-1) ?
+                                         ", %s)" : ", %s";
++                
++                if (!name) {
++                    return nullptr;
++                }
+                 name = JS_sprintf_append(name, fmt,
+                                          array[i]->GetNameString());
+             }
+         }
+     }
+-    if (!name) {
+-        return nullptr;
+-    }
+     const char* fmt = "[xpconnect wrapped %s" FMT_ADDR FMT_STR(" (native")
+         FMT_ADDR FMT_STR(")") "]";
+     if (si) {
index 05e55c8f784dd2974046e66ba3839ad375445818..4b7e0269c381d206aea22a0e649e1fb35801eaa8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -156,6 +156,9 @@ src_prepare() {
        eapply "${WORKDIR}"/firefox
        popd &>/dev/null || die
 
+       # gcc9 patch #685092
+       eapply "${FILESDIR}"/${PN}-gcc9.patch
+
        if grep -q '^sdkdir.*$(MOZ_APP_NAME)-devel' mozilla/config/baseconfig.mk ; then
                sed '/^sdkdir/s@-devel@@' \
                        -i mozilla/config/baseconfig.mk || die