dev-libs/libtpms: Add libressl support
authorSalah Coronya <salah.coronya@gmail.com>
Mon, 13 Jan 2020 05:50:43 +0000 (23:50 -0600)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 19 Feb 2020 13:32:14 +0000 (15:32 +0200)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Salah Coronya <salah.coronya@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/libtpms/libtpms-0.7.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/libtpms/libtpms-0.7.0-r1.ebuild b/dev-libs/libtpms/libtpms-0.7.0-r1.ebuild
new file mode 100644 (file)
index 0000000..b13d07d
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library providing software emultion of a TPM"
+HOMEPAGE="https://github.com/stefanberger/libtpms"
+SRC_URI="https://github.com/stefanberger/libtpms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl"
+
+DEPEND=" !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+         --with-openssl \
+         --with-tpm2
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}