Cleanup and version bump to a snapshot because of bug #168317 and #159273
authorPatrick Kursawe <phosphan@gentoo.org>
Tue, 17 Apr 2007 10:30:30 +0000 (10:30 +0000)
committerPatrick Kursawe <phosphan@gentoo.org>
Tue, 17 Apr 2007 10:30:30 +0000 (10:30 +0000)
Package-Manager: portage-2.1.1-r2

media-video/camstream/ChangeLog
media-video/camstream/camstream-20070315.ebuild [new file with mode: 0644]
media-video/camstream/files/20070315.patch [new file with mode: 0644]
media-video/camstream/files/digest-camstream-20070315 [new file with mode: 0644]

index 22bd8e0d2bd305ca0c494afd62b09a9164f01e99..d2a1ddadaf1c72f6d655171e7694296c55c5f9a8 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for media-video/camstream
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/camstream/ChangeLog,v 1.16 2007/02/09 08:01:42 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/camstream/ChangeLog,v 1.17 2007/04/17 10:30:30 phosphan Exp $
+
+*camstream-20070315 (17 Apr 2007)
+
+  17 Apr 2007; Patrick Kursawe <phosphan@gentoo.org>
+  -files/camstream-0.26.2-gcc33-multiline-string-fix.patch,
+  +files/20070315.patch, -files/uicmocpath.patch,
+  +camstream-20070315.ebuild:
+  Cleanup of old version and a version bump to a snapshot because 
+  of bug #168317 and #159273.
 
   09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
   Regenerate digest in Manifest2 format.
diff --git a/media-video/camstream/camstream-20070315.ebuild b/media-video/camstream/camstream-20070315.ebuild
new file mode 100644 (file)
index 0000000..98e9f87
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/camstream/camstream-20070315.ebuild,v 1.1 2007/04/17 10:30:30 phosphan Exp $
+
+inherit eutils libtool autotools
+
+MY_PV=${PV:2}
+
+DESCRIPTION="Collection of tools for webcams and other video devices"
+HOMEPAGE="http://www.smcc.demon.nl/camstream/"
+SRC_URI="http://www.smcc.demon.nl/camstream/download/camstream-snapshot-${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+# amd64, please update the patch
+KEYWORDS="~amd64 -ppc ~x86"
+SLOT="0"
+IUSE="doc mmx"
+
+RDEPEND="=x11-libs/qt-3*"
+DEPEND="${RDEPEND}
+       sys-devel/libtool
+       sys-devel/autoconf"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="1.9.6"
+
+src_unpack () {
+       unpack ${A}
+       cd ${S}
+       epatch ${FILESDIR}/${PV}.patch
+       for dir in ${S} ${S}/ccvt; do
+               cd ${dir}
+               eautoconf
+               elibtoolize
+               libtoolize --copy --force
+       done
+       # Camstream has 32 bit asssembler normally.
+       # patch has to be adapted
+       #use amd64 && epatch ${FILESDIR}/x86_64-asm.patch
+       #disabling mmx for amd64 as a workaround
+}
+
+src_compile () {
+       local myconf
+       # Need to fake out Qt or we'll get sandbox problems
+       REALHOME="$HOME"
+       mkdir -p $T/fakehome/.qt
+       export HOME="$T/fakehome"
+       addwrite "${QTDIR}/etc/settings"
+       if ! use mmx || use amd64; then
+               myconf="--disable-mmx"
+       fi
+       econf ${myconf} || die "configure failed"
+       emake || die "emake failed"
+}
+
+src_install () {
+       make DESTDIR=${D} install
+}
diff --git a/media-video/camstream/files/20070315.patch b/media-video/camstream/files/20070315.patch
new file mode 100644 (file)
index 0000000..820c46e
--- /dev/null
@@ -0,0 +1,29 @@
+--- camstream-070315/ccvt/ccvt_mmx.S   2006-12-20 20:13:14.000000000 +0100
++++ camstream-070315.new/ccvt/ccvt_mmx.S       2007-04-13 11:56:12.000000000 +0200
+@@ -347,3 +346,6 @@
+       END_LOOP_24
+       LEAVE_FUNC
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
+--- camstream-070315/camstream/video/video_asm.S       2006-11-17 00:58:21.000000000 +0100
++++ camstream-070315.new/camstream/video/video_asm.S   2007-04-17 00:17:12.000000000 +0200
+@@ -166,3 +166,7 @@
+ #endif /* HAVE_MMX */
+ #endif /* HAVE_INTELCPU */
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
++
+--- camstream-070315/camstream/video/video_asm_add.S   2006-11-17 00:58:21.000000000 +0100
++++ camstream-070315.new/camstream/video/video_asm_add.S       2007-04-17 00:17:37.000000000 +0200
+@@ -114,3 +114,7 @@
+       ret
+ #endif /* HAVE_INTELCPU */
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
++
diff --git a/media-video/camstream/files/digest-camstream-20070315 b/media-video/camstream/files/digest-camstream-20070315
new file mode 100644 (file)
index 0000000..e344cf5
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 2f7f7529ce6847593c2132e8dba153bc camstream-snapshot-070315.tar.gz 3943546
+RMD160 e53640e7e039a349c5ba8beb8b09f0eb7b18b69e camstream-snapshot-070315.tar.gz 3943546
+SHA256 812ab4ed0d5393ff793ea6b1dc2d18aa36beca9163d4611d8a8d56f948dd29ba camstream-snapshot-070315.tar.gz 3943546