dev-python/geventhttpclient: bump to 1.4.0
authorLouis Sautier <sbraz@gentoo.org>
Fri, 22 May 2020 20:40:40 +0000 (22:40 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Fri, 22 May 2020 20:44:40 +0000 (22:44 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/geventhttpclient/Manifest
dev-python/geventhttpclient/geventhttpclient-1.4.0.ebuild [new file with mode: 0644]

index aca04622a7d26a52e68890b4078a08e95cf34ce9..f754b4a74af5abafc1715d4a88dc118182e0143a 100644 (file)
@@ -1 +1,2 @@
 DIST geventhttpclient-1.3.1.tar.gz 82598 BLAKE2B 5fef20a74c431ed53be4eedb3ec7e040572ad960363d41dda8b93c8f08f3eb05ba6160676c1c3ed957d1528a12aa297400063377f3788754e9e76401bb3421ae SHA512 a50486e1485c449a821176f0aa139cb05a3c7675fb045086e086cc7bb71d6e1d75191fae6972b381e7e69dba89d23c387464503845badd29fa361e03aa866079
+DIST geventhttpclient-1.4.0.tar.gz 55844 BLAKE2B 2f025acdea114f513c395f58b585b282e89fca66efd778b3d10a6156e88576f3585cfd20fd84c5cf16798be461ddbfc16a0844074ebc1e96c99aab178852dfc4 SHA512 73adb1fbae7b47e1e89c2c589c58d0d22502a81b8e37596706d284f3ef44a67c7ce9c15a8fbbd375cbf6d80adc7a35727276976bad9686c622fec1380b9876e3
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.4.0.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.4.0.ebuild
new file mode 100644 (file)
index 0000000..f65c046
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
+HOMEPAGE="https://github.com/gwik/geventhttpclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/certifi[${PYTHON_USEDEP}]
+       dev-python/gevent[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       test? (
+               ${RDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )
+"
+
+python_prepare_all() {
+       # Skip SNI tests which require dpkt
+       sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       local skipped_tests=(
+               # Require network access
+               src/geventhttpclient/tests/test_client.py::test_client_simple
+               src/geventhttpclient/tests/test_client.py::test_client_without_leading_slash
+               src/geventhttpclient/tests/test_client.py::test_request_with_headers
+               src/geventhttpclient/tests/test_client.py::test_response_context_manager
+               src/geventhttpclient/tests/test_client.py::test_client_ssl
+               src/geventhttpclient/tests/test_client.py::test_ssl_fail_invalid_certificate
+               src/geventhttpclient/tests/test_client.py::test_multi_queries_greenlet_safe
+               # Require dpkg
+               src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
+               src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
+               src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
+       )
+       # Append to sys.path to avoid ImportError
+       # https://bugs.gentoo.org/667758
+       pytest --import-mode=append -vv ${skipped_tests[@]/#/--deselect } \
+               || die "Tests failed with ${EPYTHON}"
+}