dev-python/pyfakefs: version bump to 3.4.1
authorTim Harder <radhermit@gentoo.org>
Sat, 24 Mar 2018 13:00:27 +0000 (09:00 -0400)
committerTim Harder <radhermit@gentoo.org>
Sat, 24 Mar 2018 13:17:31 +0000 (09:17 -0400)
dev-python/pyfakefs/Manifest
dev-python/pyfakefs/files/pyfakefs-3.4.1-tests.patch [new file with mode: 0644]
dev-python/pyfakefs/pyfakefs-3.4.1.ebuild [new file with mode: 0644]

index 4119d7c6310971e5a83e729ab1aa42fc1fbdfab0..b60e61ccabc62242db06b12830aee22fa683f928 100644 (file)
@@ -1 +1,2 @@
 DIST pyfakefs-3.3.tar.gz 141704 BLAKE2B f805146024d9886ce6cb25b23f6f818bb37cac00a51528375b3da3e728515cb5ffd292352888861ff2b434ff71dd730bfbd84874fee0ae1f4d2cfca974f73771 SHA512 0044643964a4f2329d777476940b38d2d63c6de8f854992b4fba7b7e49f1186e7ce9811f83c9870655cbe33b7dda816c1aa1ce685e800e55c06d175c281748b7
+DIST pyfakefs-3.4.1.tar.gz 151662 BLAKE2B cbfdd7ab4c2936d484b5ff1e22852438c5c653e8875b7d363324e0a1aed0bfc5c492c2cd5c64a47052fcb4d043f567819f32067527b870ab42da8cfd92d40be3 SHA512 1be0254455f6046f1d28bf4377d17e0fb943b4b0db09e933c114f587f3d917877b23ee1610cf83a6330b406bb9ae66fe79dea31a6bf75c0b9c2b79a88d07e753
diff --git a/dev-python/pyfakefs/files/pyfakefs-3.4.1-tests.patch b/dev-python/pyfakefs/files/pyfakefs-3.4.1-tests.patch
new file mode 100644 (file)
index 0000000..d893a3a
--- /dev/null
@@ -0,0 +1,40 @@
+Drop checks that fail due to sandboxing and skip failing tell check.
+
+--- pyfakefs-3.4.1/tests/fake_os_test.py
++++ pyfakefs-3.4.1/tests/fake_os_test.py
+@@ -449,7 +449,6 @@
+         self.os.chdir(directory)
+         self.assert_raises_os_error(dir_error, self.os.remove, dir_path)
+         self.assertTrue(self.os.path.exists(dir_path))
+-        self.assert_raises_os_error(errno.ENOENT, self.os.remove, '/plugh')
+     def test_remove_dir_linux(self):
+         self.check_linux_only()
+@@ -963,6 +962,8 @@
+             self.assertEqual(b'\0\0abcde', f.read())
+     def test_append_mode_tell_linux_windows(self):
++        # skipping real fs test - python2 on the actual filesystem is also 7
++        self.skip_real_fs()
+         self.check_linux_and_windows()
+         tell_result = 5 if self.is_python2 else 7
+         self.check_append_mode_tell_after_truncate(tell_result)
+@@ -1885,8 +1886,8 @@
+         # trying to create a link from a non-existent file should fail
+         self.skip_if_symlink_not_supported()
+         self.assert_raises_os_error(errno.ENOENT,
+-                                    self.os.link, '/nonexistent_source',
+-                                    '/link_dest')
++                                    self.os.link, 'nonexistent_source',
++                                    'link_dest')
+     def test_link_delete(self):
+         self.skip_if_symlink_not_supported()
+@@ -2233,7 +2234,6 @@
+         self.os.chdir(directory)
+         self.assert_raises_os_error(dir_error, self.os.remove, dir_path)
+         self.assertTrue(self.os.path.exists(dir_path))
+-        self.assert_raises_os_error(errno.ENOENT, self.os.remove, '/Plugh')
+     def test_remove_dir_mac_os(self):
+         self.check_macos_only()
diff --git a/dev-python/pyfakefs/pyfakefs-3.4.1.ebuild b/dev-python/pyfakefs/pyfakefs-3.4.1.ebuild
new file mode 100644 (file)
index 0000000..36f46d5
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="a fake file system that mocks the Python file system modules"
+HOMEPAGE="https://github.com/jmcgeheeiv/pyfakefs/ https://pypi.python.org/pypi/pyfakefs"
+SRC_URI="https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
+python_test() {
+       "${PYTHON}" tests/all_tests.py || die "tests failed under ${EPYTHON}"
+}