kde-misc/plasma-applet-network-monitor: Switch to ecm.eclass
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 16 Mar 2020 21:20:04 +0000 (22:20 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 16 Mar 2020 21:28:33 +0000 (22:28 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-misc/plasma-applet-network-monitor/plasma-applet-network-monitor-1.7.3-r1.ebuild

index 5abe0011e6c97ce1a77c2c62600cf225ed7fe525..be6fc2cc159b304a46061019ce680a8ea31fc7e6 100644 (file)
@@ -3,19 +3,26 @@
 
 EAPI=7
 
-inherit kde5
+inherit ecm
+
+if [[ ${PV} = *9999* ]] ; then
+       EGIT_REPO_URI="https://github.com/kotelnik/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/kotelnik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64"
+fi
 
 DESCRIPTION="Plasma 5 applet for monitoring active network connections"
 HOMEPAGE="https://store.kde.org/p/998914/
 https://github.com/kotelnik/plasma-applet-network-monitor"
-SRC_URI="https://github.com/kotelnik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="GPL-2+"
-KEYWORDS="~amd64 ~arm64"
+SLOT="5"
 IUSE=""
 
 DEPEND="
-       $(add_frameworks_dep plasma)
+       >=kde-frameworks/plasma-5.60.0:5
 "
 RDEPEND="${DEPEND}"