app-text/poppler: Stop enforcing a particular c++ver
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 10 Oct 2019 19:21:27 +0000 (21:21 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 10 Oct 2019 19:24:50 +0000 (21:24 +0200)
Outdated now, and build system does the right thing at this point.

Reported-by: Francesco Riosa <vivo75@gmail.com>
Closes: https://bugs.gentoo.org/697434
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-text/poppler/poppler-0.81.0.ebuild
app-text/poppler/poppler-9999.ebuild

index 7297bf7836a108fdb037d6bfe54df37394689073..7311a1ffbf3e82c4df692ef1d91db0754b5faaa4 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
+inherit cmake-utils toolchain-funcs xdg-utils
 
 if [[ ${PV} == *9999* ]] ; then
        inherit git-r3
@@ -79,9 +79,6 @@ src_prepare() {
        else
                einfo "policy(SET CMP0002 OLD) - workaround can be removed"
        fi
-
-       # we need to up the C++ version, bug #622526, #643278
-       append-cxxflags -std=c++11
 }
 
 src_configure() {
index 7297bf7836a108fdb037d6bfe54df37394689073..7311a1ffbf3e82c4df692ef1d91db0754b5faaa4 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
+inherit cmake-utils toolchain-funcs xdg-utils
 
 if [[ ${PV} == *9999* ]] ; then
        inherit git-r3
@@ -79,9 +79,6 @@ src_prepare() {
        else
                einfo "policy(SET CMP0002 OLD) - workaround can be removed"
        fi
-
-       # we need to up the C++ version, bug #622526, #643278
-       append-cxxflags -std=c++11
 }
 
 src_configure() {