dev-perl/Symbol-Global-Name: Add build fix for Perl 5.26, bug 623106
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 3 Jul 2017 21:23:59 +0000 (23:23 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 3 Jul 2017 21:23:59 +0000 (23:23 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-perl/Symbol-Global-Name/Symbol-Global-Name-0.50.0.ebuild

index d453911b6c14112ce24ed8ae83219270468e94db..94bf6565653c76639dd93855a732303ffa724363 100644 (file)
@@ -1,10 +1,10 @@
 # Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
-MODULE_AUTHOR=ALEXMV
-MODULE_VERSION=0.05
+DIST_AUTHOR=ALEXMV
+DIST_VERSION=0.05
 inherit perl-module
 
 DESCRIPTION="Finds name and type of a global variable"
@@ -19,4 +19,8 @@ DEPEND="${RDEPEND}
        test? ( >=virtual/perl-Test-Simple-0.96 )
 "
 
-SRC_TEST="do"
+src_prepare() {
+       sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}