dev-libs/libutf8proc: fix build on Prefix
authorVirgil Dupras <vdupras@gentoo.org>
Tue, 7 May 2019 13:58:40 +0000 (09:58 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 7 May 2019 13:58:40 +0000 (09:58 -0400)
Closes: https://bugs.gentoo.org/685266
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch
dev-libs/libutf8proc/libutf8proc-2.3.0-r1.ebuild [moved from dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild with 88% similarity]

index 5750b43ad5fceead8f1884d3c830cd45266c8e68..f438fdd9779bae9f080133b19aba6894f59aa701 100644 (file)
@@ -6,7 +6,7 @@ index f5d1dd9..60c09e3 100644
  MAKE=make
  JULIA=julia
  CURLFLAGS = --retry 5 --location
-+UDATA=/usr/share/unicode-data
++UDATA=${EPREFIX}/usr/share/unicode-data
  
  .PHONY: clean
  
similarity index 88%
rename from dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild
rename to dev-libs/libutf8proc/libutf8proc-2.3.0-r1.ebuild
index 3b3b3a532031e66859206895033d098b8e2eaa07..3d5231b82df91acf36949582dfdc237e5a1f4d5c 100644 (file)
@@ -26,8 +26,15 @@ PATCHES=(
        "${FILESDIR}/${PN}-2.3.0-tests-nofetch.patch"
 )
 
+src_compile() {
+       emake CC=$(tc-getCC) AR=$(tc-getAR)
+}
+
 src_install() {
-       emake DESTDIR="${D}" prefix=/usr libdir=/usr/$(get_libdir) install
+       emake DESTDIR="${D}" \
+               prefix="${EPREFIX}/usr" \
+               libdir="${EPREFIX}/usr/$(get_libdir)" \
+               install
        # This package used to use netsurf's version as an upstream, which lives in
        # its own little world. Unlike julia's version, it puts its header file
        # in libutf8proc/utf8proc.h instead of utf8proc.h. The problem is that