media-sound/adplay: cleanup
authorMikle Kolyada <zlogene@gentoo.org>
Fri, 28 Feb 2020 08:10:55 +0000 (11:10 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Fri, 28 Feb 2020 08:11:07 +0000 (11:11 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
media-sound/adplay/Manifest [deleted file]
media-sound/adplay/adplay-1.7.ebuild [deleted file]
media-sound/adplay/adplay-1.8.ebuild [deleted file]
media-sound/adplay/files/adplay-1.7-fix-c++14.patch [deleted file]
media-sound/adplay/metadata.xml [deleted file]

diff --git a/media-sound/adplay/Manifest b/media-sound/adplay/Manifest
deleted file mode 100644 (file)
index 95a5684..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST adplay-1.7.tar.bz2 264340 BLAKE2B ea9231c66a8233ee1d026bccd073440cbbc0e8868469aee33ec0e18c7d893fa24dd20bb4fe960f908db0666e7ee5c6a4afd14051b851b011418796cc0cc2c939 SHA512 854a9bee1057d3a42308d9149e74a8abae0b6bdfda5e1466086df9d6aeed4bbc92a045bca02917fc699b43195572b39c6316ddf56ee3441add1a01d6cbbdfcbe
-DIST adplay-1.8.tar.bz2 333582 BLAKE2B e5d0e3baf3f37adb1a2f42eee368fbbcb3947b0c651415b60d5f1d648d004789eae0ef75b7e6ac8ad9f90ac9941332e713e36555167648a40a871659083d1b59 SHA512 6a82b10fa73ad9317303da03d2fcb1fa97772d850f3f78f53c554b9daaa9ae5d04bc2f0a1b1d25fd5d3a1eab073641d6fa0589070721612987d57762f03363c7
diff --git a/media-sound/adplay/adplay-1.7.ebuild b/media-sound/adplay/adplay-1.7.ebuild
deleted file mode 100644 (file)
index f74ad97..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A console player for AdLib music"
-HOMEPAGE="http://adplug.sourceforge.net"
-SRC_URI="mirror://sourceforge/adplug/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="alsa ao oss sdl"
-
-RDEPEND=">=media-libs/adplug-2.2.1
-       dev-cpp/libbinio
-       alsa? ( media-libs/alsa-lib )
-       ao? ( media-libs/libao )
-       sdl? ( media-libs/libsdl )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/${PN}-1.7-fix-c++14.patch" )
-
-src_configure() {
-       econf \
-               --disable-output-esound \
-               $(use_enable alsa output-alsa) \
-               $(use_enable ao output-ao) \
-               $(use_enable oss output-oss) \
-               $(use_enable sdl output-sdl)
-}
diff --git a/media-sound/adplay/adplay-1.8.ebuild b/media-sound/adplay/adplay-1.8.ebuild
deleted file mode 100644 (file)
index 8803bc8..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="A console player for AdLib music"
-HOMEPAGE="https://adplug.github.io/"
-SRC_URI="https://github.com/adplug/adplay-unix/releases/download/v${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="alsa ao oss sdl"
-
-RDEPEND=">=media-libs/adplug-2.2.1
-       dev-cpp/libbinio
-       alsa? ( media-libs/alsa-lib )
-       ao? ( media-libs/libao )
-       sdl? ( media-libs/libsdl )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-
-src_configure() {
-       econf \
-               --disable-output-esound \
-               $(use_enable alsa output-alsa) \
-               $(use_enable ao output-ao) \
-               $(use_enable oss output-oss) \
-               $(use_enable sdl output-sdl)
-}
diff --git a/media-sound/adplay/files/adplay-1.7-fix-c++14.patch b/media-sound/adplay/files/adplay-1.7-fix-c++14.patch
deleted file mode 100644 (file)
index aedbbc0..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-From 48dcaa87ff91369eb41998abd72e226fe138b528 Mon Sep 17 00:00:00 2001
-From: Adam Nielsen <malvineous@shikadi.net>
-Date: Sun, 22 May 2016 08:49:47 +1000
-Subject: [PATCH] Cast -1 to unsigned int to prevent compiler error
-
----
- src/adplay.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/adplay.cc b/src/adplay.cc
-index d73ec25..da00730 100644
---- a/src/adplay.cc
-+++ b/src/adplay.cc
-@@ -90,7 +90,7 @@ static struct {
-   1, 16, 0,  // Else default to mono (until stereo w/ single OPL is fixed)
- #endif
-   MSG_NOTE,
--  -1,
-+  (unsigned int)-1,
-   NULL,
-   NULL,
-   true, false, false, false,
diff --git a/media-sound/adplay/metadata.xml b/media-sound/adplay/metadata.xml
deleted file mode 100644 (file)
index dc329ba..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="project">
-               <email>sound@gentoo.org</email>
-               <name>Gentoo Sound project</name>
-       </maintainer>
-       <upstream>
-               <remote-id type="sourceforge">adplug</remote-id>
-               <remote-id type="github">adplug/adplay-unix</remote-id>
-       </upstream>
-</pkgmetadata>