dev-python/frozen-flask: fix doc build, add PyPy{,3}
authorLouis Sautier <sbraz@gentoo.org>
Sun, 24 Jun 2018 13:49:51 +0000 (15:49 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Sun, 24 Jun 2018 13:53:38 +0000 (15:53 +0200)
Also fix a minor syntax error when tests fail.

Closes: https://bugs.gentoo.org/658952
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/frozen-flask/frozen-flask-0.15.ebuild

index 8035ad11944a9717a7c2b18918e483414a2559bc..d3437227a756bf70d88e8c0eb91bac18e44842d6 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6}} )
 
 inherit distutils-r1
 
@@ -21,23 +21,19 @@ IUSE="doc test"
 RDEPEND=">=dev-python/flask-0.7[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? ( dev-python/nose[${PYTHON_USEDEP}] )"
 
 S="${WORKDIR}/${MY_P}"
 
 python_compile_all() {
        if use doc; then
-               sed -e 's:^intersphinx_mapping:#intersphinx_mapping:' -i docs/conf.py || die
-               mkdir docs/_build || die
+               sed -i "s/'sphinx.ext.intersphinx'//" -i docs/conf.py || die
                sphinx-build -c docs docs docs/_build  || die
+               HTML_DOCS=( docs/_build/. )
        fi
 }
 
 python_test() {
-       nosetests || die Tests failed under $"{EPYTHON}"
-}
-
-python_install_all() {
-       use doc && HTML_DOCS=( "${S}"/docs/_build/. )
-       distutils-r1_python_install_all
+       nosetests || die Tests failed under "${EPYTHON}"
 }