app-crypt/eid-mw: update live ebuild
authorAmy Liffey <amynka@gentoo.org>
Fri, 12 Jan 2018 16:50:08 +0000 (17:50 +0100)
committerAmy Liffey <amynka@gentoo.org>
Fri, 12 Jan 2018 16:53:43 +0000 (17:53 +0100)
Vincent Hardy <vincent.hardy.be@gmail.com>

Package-Manager: Portage-2.3.13, Repoman-2.3.3

app-crypt/eid-mw/eid-mw-9999.ebuild

index 4b7c9eadb75d817092b9c168f23bf37a6bd5428d..2b7c0eb2f88fc184d5ae7d1eb9bbef4eb021e69e 100644 (file)
@@ -1,32 +1,28 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
-inherit eutils autotools mozextension multilib
+inherit autotools mozextension gnome2-utils
 
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://github.com/Fedict/${PN}.git"
        inherit git-r3
        SRC_URI=""
 else
-       SRC_URI="https://codeload.github.com/fedict/${PN}/tar.gz/v${PV} ->
-       ${P}.tar.gz"
+       SRC_URI="https://codeload.github.com/fedict/${PN}/tar.gz/v${PV} -> ${P}.tar.gz"
        KEYWORDS="~x86 ~amd64 ~arm"
 fi
 
-SLOT="0"
-LICENSE="LGPL-3"
 DESCRIPTION="Electronic Identity Card middleware supplied by the Belgian Federal Government"
-
 HOMEPAGE="https://eid.belgium.be"
 
+LICENSE="LGPL-3"
+SLOT="0"
 IUSE="+dialogs +gtk p11-kit +xpi"
 
-REQUIRED_USE="
-       dialogs? ( gtk )"
-
-RDEPEND="gtk? (
+RDEPEND=">=sys-apps/pcsc-lite-1.2.9
+       gtk? (
                x11-libs/gdk-pixbuf[jpeg]
                x11-libs/gtk+:*
                dev-libs/libxml2
@@ -34,7 +30,6 @@ RDEPEND="gtk? (
                net-libs/libproxy
                !app-misc/eid-viewer-bin
        )
-       >=sys-apps/pcsc-lite-1.2.9
        p11-kit? ( app-crypt/p11-kit )
        xpi? ( || ( >=www-client/firefox-bin-3.6.24
                >=www-client/firefox-3.6.20 ) )"
@@ -42,8 +37,10 @@ RDEPEND="gtk? (
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
+REQUIRED_USE="dialogs? ( gtk )"
+
 src_prepare() {
-       eapply_user
+       default
 
        sed -i -e 's:/beid/rsaref220:/rsaref220:' configure.ac || die
        sed -i -e 's:/beid::' cardcomm/pkcs11/src/libbeidpkcs11.pc.in || die
@@ -62,31 +59,45 @@ src_configure() {
        econf \
                $(use_enable dialogs) \
                $(use_enable p11-kit p11kit) \
-               $(use_with gtk gtkvers)$(use gtk && echo =detect) \
+               $(use_with gtk gtkvers 'detect') \
                --with-gnu-ld \
                --disable-static \
                --disable-signed
 }
 
 src_install() {
-       emake DESTDIR="${D}" install
+       default
 
        if use xpi; then
                declare MOZILLA_FIVE_HOME
                if has_version '>=www-client/firefox-3.6.20'; then
                        MOZILLA_FIVE_HOME="/usr/$(get_libdir)/firefox"
-                       xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+                       xpi_install "${ED}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
                fi
                if has_version '>=www-client/firefox-bin-3.6.24'; then
                        MOZILLA_FIVE_HOME="/opt/firefox"
-                       xpi_install "${D}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
+                       xpi_install "${ED}/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/belgiumeid@eid.belgium.be"
                fi
+       else
+               rm -r "${ED}"/usr/$(get_libdir)/mozilla || die
+       fi
+       rm -r "${ED}/usr/share/mozilla" "${ED}"/usr/$(get_libdir)/*.la || die
+
+       if use gtk; then
+               rm -r "${ED}/usr/include/eid-util" || die
+       fi
+}
+
+pkg_postinst(){
+       if use gtk; then
+               gnome2_schemas_update
+               gnome2_icon_cache_update
        fi
-       rm -r "${D}/usr/share/mozilla" "${D}"/usr/$(get_libdir)/*.la || die
-       use gtk || rm -r "${D}/usr/include/eid-util" || die
 }
 
-pkg_postinst()
-{
-       use gtk && glib-compile-schemas /usr/share/glib-2.0/schemas/
+pkg_postrm(){
+       if use gtk; then
+               gnome2_schemas_update
+               gnome2_icon_cache_update
+       fi
 }