dev-libs/rlottie: new package
authorJoonas Niilola <juippis@gentoo.org>
Sat, 21 Sep 2019 07:31:00 +0000 (10:31 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Sat, 21 Sep 2019 07:31:19 +0000 (10:31 +0300)
 - A platform independent standalone c++ library for rendering vector
   based animations and art in realtime.

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/rlottie/Manifest [new file with mode: 0644]
dev-libs/rlottie/metadata.xml [new file with mode: 0644]
dev-libs/rlottie/rlottie-0.0.1_pre20190920.ebuild [new file with mode: 0644]

diff --git a/dev-libs/rlottie/Manifest b/dev-libs/rlottie/Manifest
new file mode 100644 (file)
index 0000000..0a8e05f
--- /dev/null
@@ -0,0 +1 @@
+DIST rlottie-0.0.1_pre20190920.tar.gz 7891127 BLAKE2B bc9e37e74f21f681fffae3e6140662782ebce7bee58c4205cdb9f927f5246aedc83efc516adecf6c61fb5fc06aff58d1c65bfe3cca18d02bf4e9f2d71890869e SHA512 8d903e877cb83fd0af8cb7b6dd96e09a423201c0b88b2c8c733e54bb873a7b48377e5eb8eeefa620e284c2d1b61fcfe0aa309d180c88428aaccdb0f1ac4a48ed
diff --git a/dev-libs/rlottie/metadata.xml b/dev-libs/rlottie/metadata.xml
new file mode 100644 (file)
index 0000000..6b0a0fb
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>juippis@gentoo.org</email>
+    <name>Joonas Niilola</name>
+  </maintainer>
+</pkgmetadata>
diff --git a/dev-libs/rlottie/rlottie-0.0.1_pre20190920.ebuild b/dev-libs/rlottie/rlottie-0.0.1_pre20190920.ebuild
new file mode 100644 (file)
index 0000000..91fc118
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+MY_COMMIT="93dd5305d9f5d2270a873c9c565b6931439fd11f"
+
+DESCRIPTION="A platform independent standalone library that plays Lottie Animations"
+HOMEPAGE="https://www.tizen.org/ https://github.com/Samsung/rlottie"
+SRC_URI="https://github.com/Samsung/rlottie/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD FTL LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+
+S="${WORKDIR}/rlottie-${MY_COMMIT}"
+
+src_configure() {
+       local emesonargs=(
+               $(meson_use test)
+       )
+
+       meson_src_configure
+}
+
+src_test() {
+       cd "${BUILD_DIR}" || die "Failed to switch into BUILD_DIR."
+       eninja test
+}