dev-lang/gnat-gpl: put a guards against tool renaming made twice
authorTupone Alfredo <tupone@gentoo.org>
Fri, 22 Nov 2019 12:02:54 +0000 (13:02 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Fri, 22 Nov 2019 12:03:28 +0000 (13:03 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-lang/gnat-gpl/gnat-gpl-2016-r4.ebuild
dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild
dev-lang/gnat-gpl/gnat-gpl-2018-r3.ebuild
dev-lang/gnat-gpl/gnat-gpl-2019-r1.ebuild

index 2cbd328b44889341ca4e70797151ac488fcd37b8..290798ee35e78bc291b45e4261c6b6719f74af2f 100644 (file)
@@ -172,6 +172,9 @@ src_compile() {
 src_install() {
        toolchain_src_install
        cd "${D}"${BINPATH}
+       if [[ -h gnatmake-${GCC_CONFIG_VER} ]] ; then
+               return
+       fi
        for x in gnat*; do
                # For some reason, g77 gets made instead of ${CTARGET}-g77...
                # this should take care of that
@@ -183,11 +186,9 @@ src_install() {
                fi
 
                if [[ -f ${CTARGET}-${x} ]] ; then
-                       if ! is_crosscompile ; then
-                               ln -sf ${CTARGET}-${x} ${x}
-                               dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                                       /usr/bin/${x}-${GCC_CONFIG_VER}
-                       fi
+                       ln -sf ${CTARGET}-${x} ${x}
+                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
+                               /usr/bin/${x}-${GCC_CONFIG_VER}
                        # Create versioned symlinks
                        dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
                                /usr/bin/${CTARGET}-${x}-${GCC_CONFIG_VER}
index 0ea6d3ee076258dc818f1f3f6c23fa7935ba0256..8d63c01d4ee4dc961425f2bf71e651e899481db0 100644 (file)
@@ -154,6 +154,9 @@ src_compile() {
 src_install() {
        toolchain_src_install
        cd "${D}"${BINPATH}
+       if [[ -h gnatmake-${GCC_CONFIG_VER} ]] ; then
+               return
+       fi
        for x in gnat*; do
                # For some reason, g77 gets made instead of ${CTARGET}-g77...
                # this should take care of that
@@ -165,11 +168,9 @@ src_install() {
                fi
 
                if [[ -f ${CTARGET}-${x} ]] ; then
-                       if ! is_crosscompile ; then
-                               ln -sf ${CTARGET}-${x} ${x}
-                               dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                                       /usr/bin/${x}-${GCC_CONFIG_VER}
-                       fi
+                       ln -sf ${CTARGET}-${x} ${x}
+                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
+                               /usr/bin/${x}-${GCC_CONFIG_VER}
                        # Create versioned symlinks
                        dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
                                /usr/bin/${CTARGET}-${x}-${GCC_CONFIG_VER}
index 00f3295d1ceee07434312f1d415dc14d1f5761f5..1e8dadcdd4d993d115ceb9019d27e0444836387f 100644 (file)
@@ -154,6 +154,9 @@ src_compile() {
 src_install() {
        toolchain_src_install
        cd "${D}"${BINPATH}
+       if [[ -h gnatmake-${GCC_CONFIG_VER} ]] ; then
+               return
+       fi
        for x in gnat*; do
                # For some reason, g77 gets made instead of ${CTARGET}-g77...
                # this should take care of that
@@ -165,11 +168,9 @@ src_install() {
                fi
 
                if [[ -f ${CTARGET}-${x} ]] ; then
-                       if ! is_crosscompile ; then
-                               ln -sf ${CTARGET}-${x} ${x}
-                               dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                                       /usr/bin/${x}-${GCC_CONFIG_VER}
-                       fi
+                       ln -sf ${CTARGET}-${x} ${x}
+                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
+                               /usr/bin/${x}-${GCC_CONFIG_VER}
                        # Create versioned symlinks
                        dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
                                /usr/bin/${CTARGET}-${x}-${GCC_CONFIG_VER}
index fe915188aa116e9d3e72df05c0fd102b3073bc5c..ec50a7c0fb5640cc1a29dea607b1dc9dcc5cde5a 100644 (file)
@@ -153,6 +153,9 @@ src_compile() {
 src_install() {
        toolchain_src_install
        cd "${D}"${BINPATH}
+       if [[ -h gnatmake-${GCC_CONFIG_VER} ]] ; then
+               return
+       fi
        for x in gnat*; do
                # For some reason, g77 gets made instead of ${CTARGET}-g77...
                # this should take care of that
@@ -164,11 +167,9 @@ src_install() {
                fi
 
                if [[ -f ${CTARGET}-${x} ]] ; then
-                       if ! is_crosscompile ; then
-                               ln -sf ${CTARGET}-${x} ${x}
-                               dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
-                                       /usr/bin/${x}-${GCC_CONFIG_VER}
-                       fi
+                       ln -sf ${CTARGET}-${x} ${x}
+                       dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
+                               /usr/bin/${x}-${GCC_CONFIG_VER}
                        # Create versioned symlinks
                        dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
                                /usr/bin/${CTARGET}-${x}-${GCC_CONFIG_VER}