app-i18n/fcitx: Use ${Fcitx_major_version}.9999 version scheme for live ebuild.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Tue, 26 Sep 2017 20:38:01 +0000 (22:38 +0200)
committerMike Gilbert <floppym@gentoo.org>
Wed, 27 Sep 2017 19:56:56 +0000 (15:56 -0400)
app-i18n/fcitx/fcitx-4.2.9.3.ebuild
app-i18n/fcitx/fcitx-4.9999.ebuild [moved from app-i18n/fcitx/fcitx-9999.ebuild with 97% similarity]

index 6a1c4258963dc13ecae482ce6a7d749ac5abe340..a6b5e59f5762ee56b2f8d0ca1ff911a21517e6e1 100644 (file)
@@ -5,7 +5,7 @@ EAPI="6"
 
 inherit cmake-utils gnome2-utils xdg-utils
 
-if [[ "${PV}" == "9999" ]]; then
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
        inherit git-r3
 
        EGIT_REPO_URI="https://github.com/fcitx/fcitx"
@@ -13,7 +13,7 @@ fi
 
 DESCRIPTION="Fcitx (Flexible Context-aware Input Tool with eXtension) input method framework"
 HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx"
-if [[ "${PV}" == "9999" ]]; then
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
        SRC_URI="https://download.fcitx-im.org/data/pinyin.tar.gz -> fcitx-data-pinyin.tar.gz
                https://download.fcitx-im.org/data/table.tar.gz -> fcitx-data-table.tar.gz
                https://download.fcitx-im.org/data/py_stroke-20121124.tar.gz -> fcitx-data-py_stroke-20121124.tar.gz
@@ -77,7 +77,7 @@ PATCHES=(
 DOCS=(AUTHORS ChangeLog THANKS)
 
 src_prepare() {
-       if [[ "${PV}" == "9999" ]]; then
+       if [[ "${PV}" =~ (^|\.)9999$ ]]; then
                ln -s "${DISTDIR}/fcitx-data-pinyin.tar.gz" src/im/pinyin/data/pinyin.tar.gz || die
                ln -s "${DISTDIR}/fcitx-data-table.tar.gz" src/im/table/data/table.tar.gz || die
                ln -s "${DISTDIR}/fcitx-data-py_stroke-20121124.tar.gz" src/module/pinyin-enhance/data/py_stroke-20121124.tar.gz || die
similarity index 97%
rename from app-i18n/fcitx/fcitx-9999.ebuild
rename to app-i18n/fcitx/fcitx-4.9999.ebuild
index 92282aeb5421484abb1593e9a7048527520b507c..54b3183f34c0ccb767bcaf9d2c3d72128ac99c37 100644 (file)
@@ -5,7 +5,7 @@ EAPI="6"
 
 inherit cmake-utils gnome2-utils xdg-utils
 
-if [[ "${PV}" == "9999" ]]; then
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
        inherit git-r3
 
        EGIT_REPO_URI="https://github.com/fcitx/fcitx"
@@ -13,7 +13,7 @@ fi
 
 DESCRIPTION="Fcitx (Flexible Context-aware Input Tool with eXtension) input method framework"
 HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx"
-if [[ "${PV}" == "9999" ]]; then
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
        SRC_URI="https://download.fcitx-im.org/data/pinyin.tar.gz -> fcitx-data-pinyin.tar.gz
                https://download.fcitx-im.org/data/table.tar.gz -> fcitx-data-table.tar.gz
                https://download.fcitx-im.org/data/py_stroke-20121124.tar.gz -> fcitx-data-py_stroke-20121124.tar.gz
@@ -73,7 +73,7 @@ DEPEND="${RDEPEND}
 DOCS=(AUTHORS ChangeLog THANKS)
 
 src_prepare() {
-       if [[ "${PV}" == "9999" ]]; then
+       if [[ "${PV}" =~ (^|\.)9999$ ]]; then
                ln -s "${DISTDIR}/fcitx-data-pinyin.tar.gz" src/im/pinyin/data/pinyin.tar.gz || die
                ln -s "${DISTDIR}/fcitx-data-table.tar.gz" src/im/table/data/table.tar.gz || die
                ln -s "${DISTDIR}/fcitx-data-py_stroke-20121124.tar.gz" src/module/pinyin-enhance/data/py_stroke-20121124.tar.gz || die