www-client/qutebrowser: cleanup live build
authorJustin Bronder <jsbronder@gentoo.org>
Thu, 26 Oct 2017 17:22:22 +0000 (13:22 -0400)
committerJustin Bronder <jsbronder@gentoo.org>
Thu, 26 Oct 2017 17:44:19 +0000 (13:44 -0400)
It's been a while since qutebrowser was in sync with upstream.  This
represents getting it back up to date.

- Python 3.4 dropped
- Drop support for webkit backend.  Requires a fork of QtWebKit which is
  not maintained by Qt.
- Updating deps
- Do not install asciidocs, they're available via html inside of the
  browser
- Migrate from fdo-mime to xdg-utils

Package-Manager: Portage-2.3.8, Repoman-2.3.3

www-client/qutebrowser/metadata.xml
www-client/qutebrowser/qutebrowser-9999.ebuild

index d59a858a3791a3deff0cdf6bb4ec76cfec359c13..7623d04971cf79b75625954e12e7d55866cde793 100644 (file)
@@ -9,10 +9,6 @@
                <email>jsbronder@gentoo.org</email>
                <name>Justin Bronder</name>
        </maintainer>
-       <use>
-               <flag name="webengine">Install packages required for
-               experimental rendering support with webengine.</flag>
-       </use>
        <upstream>
                <remote-id type="github">qutebrowser/qutebrowser</remote-id>
        </upstream>
index 2688b7223b3cff9cc63ce45f72b58a23a9cfb69c..0aa553826163aefb8681b3f558a126a42d2c3cec 100644 (file)
@@ -1,46 +1,49 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{3_5,3_6} )
 
-inherit gnome2-utils distutils-r1 eutils fdo-mime
+inherit distutils-r1 eutils gnome2-utils xdg-utils
 
 if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="https://github.com/The-Compiler/qutebrowser.git"
+       EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
        inherit git-r3
 else
-       SRC_URI="https://github.com/The-Compiler/${PN}/releases/download/v${PV}/${P}.tar.gz"
+       SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
        KEYWORDS="~amd64 ~x86"
 fi
 
-DESCRIPTION="A keyboard-driven, vim-like browser based on PyQt5 and QtWebKit / QtWebEngine"
+DESCRIPTION="A keyboard-driven, vim-like browser based on PyQt5 and QtWebEngine"
 HOMEPAGE="https://www.qutebrowser.org/ https://github.com/qutebrowser/qutebrowser"
 
 LICENSE="GPL-3"
 SLOT="0"
-IUSE="gstreamer test webengine +webkit"
-REQUIRED_USE="|| ( webengine webkit )"
+IUSE="test"
 
 COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 DEPEND="${COMMON_DEPEND}
        app-text/asciidoc
        test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
 RDEPEND="${COMMON_DEPEND}
-       >=dev-python/cssutils-1.0.1[${PYTHON_USEDEP}]
+       dev-python/attrs[${PYTHON_USEDEP}]
        >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
        >=dev-python/pygments-2.1.3[${PYTHON_USEDEP}]
        >=dev-python/pypeg2-2.15.2[${PYTHON_USEDEP}]
-       dev-python/PyQt5[${PYTHON_USEDEP},declarative,gui,network,printsupport,webengine?,webkit?,widgets]
-       dev-python/sip[${PYTHON_USEDEP}]
+       >=dev-python/PyQt5-5.7.1[${PYTHON_USEDEP},declarative,gui,network,opengl,printsupport,sql,webengine,widgets]
        >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
-       gstreamer? ( dev-qt/qtwebkit:5[gstreamer] )
-       webengine? (
-               >=dev-python/PyQt5-5.7.1
-               >=dev-qt/qtwebengine-5.7.1:5
-       )
 "
 
+if [[ ${PV} == "9999" ]] ; then
+       # Highlighting needed to create help files.  Alternatively,
+       # scripts/asciidoc2html.py could be patched to optionally set
+       # '--attribute pygments' when calling asciidoc
+       DEPEND="${DEPEND}
+               dev-util/source-highlight"
+fi
+
+# Tests restricted as the deplist (misc/requirements/requirements-tests.txt)
+# isn't complete and X11 is required in order to start up qutebrowser.
 RESTRICT="test"
 
 python_compile_all() {
@@ -57,7 +60,6 @@ python_test() {
 
 python_install_all() {
        doman doc/${PN}.1
-       dodoc {CHANGELOG,CONTRIBUTING,FAQ,README}.asciidoc
 
        domenu ${PN}.desktop
        doicon -s scalable icons/${PN}.svg
@@ -71,7 +73,8 @@ pkg_preinst() {
 
 pkg_postinst() {
        optfeature "PDF display support" www-plugins/pdfjs
-       fdo-mime_desktop_database_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
        gnome2_icon_cache_update
 }