sys-apps/superdiag: bump to version 1.2.0
authorConrad Kostecki <conrad@kostecki.com>
Sat, 21 Sep 2019 22:00:33 +0000 (00:00 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 13 Oct 2019 11:21:57 +0000 (14:21 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-apps/superdiag/Manifest
sys-apps/superdiag/superdiag-1.2.0.20190711.ebuild [new file with mode: 0644]

index 93dc6ed99a016a8c35f602ed20259110345f5f7a..dca4774bedc5d958211c42c89a0108d25b391d8c 100644 (file)
@@ -1 +1,2 @@
 DIST SuperDiag_1.1.0_20180731_package.zip 2564515 BLAKE2B 9ae34682daf5aa8996989c434906dd59f64e569a1cd1ae107d1e7861430ae028829efd1a1aa1ba2b5269d13e0ac2bef33b106a945fbd800fba6766b10f7486a5 SHA512 b79eae3063fc1425ee2a7a71304ae8993da52e9a2a8b2565e5f4fe0f3f3cdf8a7016cf765dab9e440c71cb8ff6b311fa2e4067459d76268bcf2697e8344c4e9a
+DIST SuperDiag_1.2.0_20190711.zip 4826479 BLAKE2B c0ffaf59ab1cbbe406a907938bf028844781533516dc6b0f2c2ee8144395da48a43e5931ef65e6990c97cfb887dd086d7535260319721b534e3b66135c37c680 SHA512 24ac9224a302e4f61a56015476b5c5fb279a057acae97e12c1e8e9271a8f410337f6182d5204d531927b0004ccb76b65c784c91be2c3644d0f30db0c8eca4c6f
diff --git a/sys-apps/superdiag/superdiag-1.2.0.20190711.ebuild b/sys-apps/superdiag/superdiag-1.2.0.20190711.ebuild
new file mode 100644 (file)
index 0000000..52739fd
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_BUILD="7119"
+MY_DATE="$(ver_cut 4)"
+MY_DATE_ISO="0711"
+MY_PN="SuperDiag"
+MY_PV="$(ver_cut 1-3)"
+MY_PV_PDF="$(ver_cut 1) $(ver_cut 2) $(ver_cut 3)"
+
+DESCRIPTION="Provides the capability to determine the health of Supermicro servers components"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_PN}_${MY_PV}_${MY_DATE}.zip"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+IUSE="iso usb"
+
+DEPEND="app-arch/unzip"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}"
+
+pkg_nofetch() {
+       elog "Please download ${A} from"
+       elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=SDO"
+       elog "and place it in your DISTDIR directory."
+}
+
+src_unpack() {
+       unpack ${A}
+
+       if use iso; then
+               unzip Diagnose_Remotely/ISOFor${MY_PN}_v${MY_PV}_${MY_BUILD}.zip -d iso || die
+       fi
+
+       if use usb; then
+               unzip Diagnose_Remotely/USBFor${MY_PN}_v${MY_PV}_${MY_BUILD}.zip -d usb || die
+       fi
+}
+
+src_install() {
+       insinto /usr/share/superdiag
+       doins startup.nsh ${MY_PN}_v${MY_PV}.efi EFI/Boot/BootX64.efi
+
+       local DOCS=(
+               "Supermicro Super Diagnostics Offline readme.txt"
+               "Supermicro Super Diagnostics Offline User Guide V${MY_PV_PDF}.pdf"
+       )
+       dodoc "${DOCS[@]}"
+
+       if use iso; then
+               insinto /usr/share/superdiag/ISO
+               doins iso/${MY_PN}_v${MY_PV}_${MY_DATE_ISO}.iso
+
+               newdoc iso/Readme.txt Readme.ISO.txt
+       fi
+
+       if use usb; then
+               insinto /usr/share/superdiag/USB
+               doins usb/STARTUP.nsh
+
+               dosym ../BootX64.efi /usr/share/superdiag/USB/BootX64.efi
+               dosym ../${MY_PN}_v${MY_PV}.efi /usr/share/superdiag/USB/${MY_PN}_v${MY_PV}.efi
+
+               newdoc usb/Readme.txt Readme.USB.txt
+       fi
+}