app-doc/doxygen: update live ebuild
authorMatthias Maier <tamiko@gentoo.org>
Sun, 1 Mar 2020 18:39:01 +0000 (12:39 -0600)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 1 Mar 2020 18:39:01 +0000 (12:39 -0600)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
app-doc/doxygen/doxygen-9999.ebuild

index fbce5ffa6dd3d4ea85822ef076637cd6ced09b01..1f26a9351fedf44b5bd7cfe9b1dee69494840fe4 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 CMAKE_MAKEFILE_GENERATOR="emake"
 
@@ -22,7 +22,7 @@ HOMEPAGE="http://www.doxygen.org"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="clang debug doc dot doxysearch latex qt5 sqlite userland_GNU"
+IUSE="clang debug doc dot doxysearch qt5 sqlite userland_GNU"
 
 RDEPEND="app-text/ghostscript-gpl
        dev-lang/perl
@@ -33,14 +33,14 @@ RDEPEND="app-text/ghostscript-gpl
                media-gfx/graphviz
                media-libs/freetype
        )
-       doxysearch? ( dev-libs/xapian:= )
-       latex? (
+       doc? (
                dev-texlive/texlive-bibtexextra
                dev-texlive/texlive-fontsextra
                dev-texlive/texlive-fontutils
                dev-texlive/texlive-latex
                dev-texlive/texlive-latexextra
        )
+       doxysearch? ( dev-libs/xapian:= )
        qt5? (
                dev-qt/qtgui:5
                dev-qt/qtwidgets:5
@@ -49,8 +49,6 @@ RDEPEND="app-text/ghostscript-gpl
        sqlite? ( dev-db/sqlite:3 )
        "
 
-REQUIRED_USE="doc? ( latex )"
-
 DEPEND="sys-devel/flex
        sys-devel/bison
        doc? ( ${PYTHON_DEPS} )
@@ -59,7 +57,10 @@ DEPEND="sys-devel/flex
 # src_test() defaults to make -C testing but there is no such directory (bug #504448)
 RESTRICT="test"
 
-PATCHES=( "${FILESDIR}/${PN}-1.8.12-link_with_pthread.patch" )
+PATCHES=(
+       "${FILESDIR}/${PN}-1.8.12-link_with_pthread.patch"
+       "${FILESDIR}/${PN}-1.8.17-ensure_static_support_libraries.patch"
+)
 DOCS=( LANGUAGE.HOWTO README.md )
 
 pkg_setup() {